Requires USB connection to start download

When I start season pass, it immediately requests that I connect my device (ATV2) via USB before it will start the download of the firmware.  This is not in accordance with the instructions and happens on 2 different PC’s (running Vista and XP).  If I momentarily connect the USB, I can get the program to proceed, but at the point where it shows that it is downloading firmware signatures, a “critical error-ensure no conflicting software is running” occurs requiring that the process be stopped.  Any help would be appreciated.

You are using 6months old version. Download the latest

Thanks for the reply. No, the Season Pass version I am using (, created 25 Jul 12) is the one downloaded from “Jailbreaking 101” as per your link.  Downloading it again does not make any difference i.e. As soon as I start the program, it wants me to connect the ATV2 via USB before it will start downloading the firmware.

Edit: I have discovered that by right clicking on “Create IPSW” I can get the download to start for iTunes Version 5.0 9B179b, but not for the two later ones.  This looks like a problem in the current version of Seasonpass.

I am having the exact same problem.  I am running Version on my ATV2 with 5.0.2 9B830.  It asks me to plug in the ATV2 before it downloads and then I get the same error at downloading firmware signatures.

Try post 12 , it should work till apple signs 5.0.2

I am having same issue.  I updated my f/w manually from ATV2 4.3 to ATV2 5.0.2.  It asks me to connect ATV via USB prior to downloading any firmware automatically…once it gets to the downloading signatures part it errors out saying that I could be running software that is interfering with the program.  I removed all antivirus software and continue to get the same message. Any help would be appreciated. edit I also read something about needing to have Netframework updated to 4.0…maybe that could be the issue as well.  I’ll check tonight and report back.

Just an update to my prior issue.  It seems that the issue WAS indeed the .net framework.  Used on a good computer running Windows 7 Ultimate X64 and everything ran seemlessly.

Shortly after I posted to this thread I got an email from FireCore support that my error message was from a server problem Monday night on their end.  When I tried it last night everything worked perfectly!  THANKS FC!

Doesn’t anyone from FC monitor this forum!  They should have announced the server problem here which would have saved me a lot of time pursuing the fixes in this and other threads.  I finally gave up based on the probably that Apple had stopped signing 5.02 because 5.1 was out.  In the end, I had to update to 5.1 for which there is no current jailbreak and, for me, no way back to an earlier version.  Yeah, “THANKS, FC!”

I beleive Apple was still signing 5.0.2 as of yesterday (Tuesday).  I was able to use itunes to restore an official 5.0.2 ipsw file yesterday afternoon to my ATV2, then last night I was able to use Seas0nPass successfully.

Hi Everyone,


I have apple tv2 4.3 (8f455) and i am getting the same error message. When it comes to the dowloading firmaware signiture it giv eme the error  “critical error-ensure no conflicting software is running” occurs requiring that the process be stopped. Any help would be appreciated


1) i tried many PCs

2) disabled the Antivirus

3) use the uptodate Seasonpass

4) no other iDevices (iPods, iPhones, iPads, etc…) are connected when restoring in iTunes.

  1. Tried  using a different USB port and/or removing any USB hub


Please help

Went to jailbreak my TV2. I downloaded the latest SeasonPass but get the connect your device message. I’m confused should it not downlaod the IPSW.

Thanks for The help