Remote HD Help

I jailbroke my Apple TV and I’m using Flash Black. Remote HD us not listed under Maintenance > Manage Extras. So I followed the other instructions you provide top install using NITO. I found it under NITO and it says "installation/upgrade successful. I return to find its nowhere to be found, not under maintenance, not under extras, not on my screen anywhere. I restarted the Apple TV and still it’s not there. My TV is running software 5.0.2. I searched your forum and found similar questions, but they remain unanswered. So can you please help me?

I am not sure what you think should be there? I have Remote HD installed on my 4.4.4 based ATV2 and all that means is that I can use the Remote HD app on my iPad to intract with the ATV2 - there is no menu item or anything like that on the ATV2 itself.

Having said that, I am not sure if the ATV end of Remote HD even works with the latest firmware. Not having upgraded yet I have not tried it out.

Hmmm, I thought there would be a menu item as I’ve seen on some of the YouTube tutorials. In any case, after it says the download was successful I still cannot get the Remote HD app on my iphone to locate the Apple TV. It finds my laptop with no issue, but not the Apple TV. Maybe b/c the update is so new. I guess I’ll have to wait for Remote HD to come out with an update then? Thanks for trying to help out. If anyone else has any other ideas please post them.

Same issue here.  I successfully jailbroke with seas0npass.  Installed aTV over LAN, but no option to enable Remote HD.  Tried installing NitoTV, Rowmote, etc., but Remote HD app on iPad still isn’t seeing my ATV2

I have seem mention that RemoteHD is not currently/yet compatible with iOS 5 0.x, which is why it’s not offered as an available download in Firecore’s “maintenance” menu.

I am jailbroken on AppleTV software 5.0.1.  And, well, good news: I checked Firecore’s Maintenance app this morning, and “Remote HD” is now being offered again.

I see @firecore mentions it on Twitter as well:

Once installed, a new button for “Remote HD” appears on the home screen. Click it – and all that is in there is the version number (4.4) and a menu command to “Hide Menu Item.” Bad news, however: if you select that, all it does is hide the version number.  The button (now even more useless, as there’s nothing displayed when you click it) does not get hidden from the Home Screen.  Also, I see no way to “unhide Menu item,” either.  And rooting around in .plist files isn’t getting me anywhere!  Ack.  Is there any way to get that version # menu item back, and if not, just hide the Remote HD button entirely?

Lastly, it appears that “uninstalling” RemoteHD via the Maintenance menu doesn’t work properly either.  I mean, the button disappears from the Home Screen and you can connect via RemoteHD any longer, but Maintenance still lists it as “installed.”  I had to fix this, somehow, by installing and removing it again via NitoTV.

Is there an easier way to reinstall (I ran in the same issues…). If not, can you share the steps to do it using NitoTV? Thanks

I only signed up here so i can share this iformation with you…

like everyone does upgrades there packages…remotehd update made my atv2 show blank screen on 4.4.3


if this has happened to you this is the fix

use putty and ssh in and type commands and hit enter after each command

“this removes”

apt-get remove remotehd-atv2



ssh back in again

“this downloads older version that worked”



“this installs it”

dpkg -i remotehd-atv2_4.3.6_iphoneos-arm.deb



hope this has helped people…RemoteHD shouldnt release non stable product until fully tested