Remote app 3.0 restarts aTV2

After updating the Remote app in my iPhone to version 3.0 it stopped working with my jailbroken Apple TV 2.
Every time I open the app, it tries to connect to the aTV2, and the aTV2 restarts and keeps restarting for as long as the remote app is open on my iPhone. The same thing happens when using Remote app 3.0 on my iPad.
Is someone else having this problem?

Same problem here.
Tested old version of remote from different iOS device and it still works fine

Yes, its happening for me too.

The updated Remote app gives specific support for the new iTunes 11, and since there is now an updated aTV firmware version also to support iTunes 11 features I can only assume that it will be necessary to have the Apple updated firmware on the aTV before the new Remote app will work.

So this will mean we will need to wait for an update for the Jailbreak and from Firecore.

Hopefully Firecore can jump in here and confirm this?

PS: So, now that we know we need to keep using the old version of the Apple Remote app for the moment, can anyone confirm if the old version of the Remote app still works if you update to iTunes 11 on the desktop?

In fact, on that same subject (and based on my theory in the previous post) does updating to iTunes 11 on the desktop break any functionality on the (not yet updated) aTV with jailbreak and atv flash?

Im holding off updating any of this new Apple stuff for the moment, since it seems it was all designed to work together and isnt necessarily backwards compatible.

Same problem for me. So how do I get back to previous version of the remote app on my iPhone? I’m running atv flash (black) 1.6 and my atv2 is running 5.0.2

If you have only updated the Remote app on your iPhone, and not on iTunes then iTunes will still have the previous version saved. So:

  • delete the new version of Remote from your phone

  • sync with iTunes

  • go to Devices > iPhone > Apps and tick Remote

  • sync again and iTunes will reinstall the previous version

NB: this only works if you havent updated to the new app on iTunes under Library > Apps > Updates Available

(and you need to remember not to update here, or the new version will get installed to your iPhone next time you sync)

Additionally, if your iPhone is jailbroken you can install a tweak to hide the update on your iPhone App Store. There are several available for free from Cydia. The one I use is ‘Update Hider’

Hope this helps, otherwise more instructions are available by searching online.

Thanks heaps jmh2002 but its my first iPhone and only a few days old so I hadn’t scynced with iTunes yet

Same problem here. I’ve asked FC for support, let’s see what happens. Glad it’s not just me!!!

I could be wrong but I dont think its anything to do with Firecore. Apple has updated iTunes, aTV, and Remote with new functionality. I think they are all designed to work together and might not be backwards compatible.

Lets see I guess.

Looking through the logs appears to give this as the crash reason:


Nov 30 10:52:51 Apple-TV AppleTV[238]: *** Assertion failure in -[ML3AggregateQuery selectPersistentIDsSQLAndProperties:ordered:], /SourceCache/MusicLibrary/MusicLibrary-972.40/ML3/ML3AggregateQuery.m:64

Nov 30 10:52:51 Apple-TV AppleTV[238]: *** Terminating app due to uncaught exception ‘NSInternalInconsistencyException’, reason: ‘Can not get aggregated properties for album_artist_pid of class ML3Album’

Yes, I agree that it would look to be unlikely that it is FC’s fault directly, but unfortunately there’s noone else we can turn to for the time being, as ios 5.0.2 is as high as we can currently go, unless the recently rumours about a forthcoming 5.1.1 JB are true (which seems unlikely?).

I haven’t tried a “clean” install of 5.0.2 to see if it does this as well - has any one else?

I did a clean install last night and get the same result. Is anyone experiencing trouble locating shares with the media app? After reinstall I can not locate the share with my most current atv2. I have another non updated atv2 which finds the share no problem.

Hey guys, I am surprised to say that the new remote seems to have no problem with my non updated atv2 (maintenance 2.0.2-4). It’s running fine… But doesn’t like the current release.

FireCore support have got back to me and have said a new version of Seasonpass is in the works (implication: that’ll fix the problem.)

Have any of you been able to boot your aTV2 without restoring it? I removed and downgraded my remote app back to 2.4 however my Apple TV is still stuck in this constant reboot state. I have turned my phone off completely and the Apple TV still wont boot.

How did you get yours to boot after having the problem?

Does anyone have a jailbroken Apple TV that DOES work with version 3.0 of the Remote app? Is everyone who uses Remote 3.0 app having this problem, or is it a subset? I feel like this thread would be way longer if it was everyone…


Also: I can confirm that Remote version 2.4 works fine to control iTunes 11 on my computer.

Thanks dlsfbdsabkfasdfkjb.  Can you (or anyone else) confirm that iTunes11 will play through an ATV2 running 5.0.2 and ATV Flash (black) 1.6? Thanks

I can confirm that iTunes 11 will airplay fine through my jailbroken ATV2 running 5.0.2

Hi friends,


I found a cool way to solve my problem of “Apple Remote 3.0 causes endless rebooting on my jailbroken Apple TV 2nd generation with iOS 5.0.2”.


The idea is to use Time Machine to restore an older version of the Remote app.


First, I delete the Remote 3.0 in my iTunes 11. Then, I navigate to this folder on my Mac and enter Time Machine:
 /Users/yourname/Music/iTunes/iTunes Media/Mobile Applications/


In Time Machine, I was able to see a “Remote 2.4.ipa” file and restored that version. I dragged this .ipa file into my iTunes library, then installed this older app onto my iPad. I had to restart my Apple TV before the Remote app would see it through Home Sharing.


Now, I am able to control my Apple TV from my iPad with no reboot problems! This was much easier than trying to trawl through Google search results, desperately looking for a link to an old version of the app. The only significant feature I’m missing is that I can’t add “Up Next” songs, but I am able to control music playback and browsing with no problems.


I am another person who can confirm that AirPlay has no problems with iTunes 11 and a jailbroken ATV with iOS 5.0.2.


^^^ Yes, basically what I said on page 1 - restore the old version for now.

Ok, you have Time machine, but for those who dont the old .ipa files end up in recycle bin (on windows - not sure about mac), or of course good practice would say that everyone is making regular backup images to an external disk and the old app could also be retrieved from there :wink:

I have the same issue with Remote 3 iOS app. After upgrading AppleTV to 5.0.2 it goes restarted when I’am using Remote on my iPhone. After downgrade to 2.4 everything works fine.