Remote access via Tailscale, without disabling system proxy

Hello,

I ran into a minor issue in Infuse for macOS and was hoping I could get some help.

I have an HTTP/HTTPS/SOCKS proxy running as system proxy on my Mac 24/7. Recently I set up Tailscale so that I can access the server from outside my home network. The issue is that Infuse can only connect to the server via Tailscale when I quit the proxy client.

My questions are: Are there some settings I can change so that Infuse can connect via Tailscale without me having to quit the proxy client? If not, would it be possible for Infuse to support it in a future update?

Some additional info:

  • Port forwarding is not an option for me, so I have to rely on Tailscale (or similar solutions) for remote access.
  • I believe the technical reasons behind this issue is on Infuse’ side (rather than Tailscale’s) because Jellyfin Media Player is able to access the server via Tailscale without disabling the proxy.
  • It can be very problematic for me to not have access to my proxy every time I want to use Infuse remotely, so I would really appreciate a permanent fix. For now I have to rely on Jellyfin for remote access.

What protocol is Jellyfin Media Player using? I’m using SMB when I stream content at home from my QNAP. Infuse is running on my ATV, iMac and also on my iPhones. All using SMB.

I don’t know the technicalities well enough to tell if it’s using SMB or other protocols.

The most relevant detail I can recall is that when adding my server to Infuse, I had to fill in <IP address>; whereas when adding to Jellyfin Media Player, I had to fill in <IP address>:8096. In both cases, the <IP address> is the virtual IP assigned by Tailscale.

I don’t have a Jellyfin server but Infuse seems to support talking to a Jellyfin server so you you should be able to have Infuse talk to the Jellyfin Server just as the Jellyfin Media Player does.

Oh, sorry for not making myself clear. I can connect to my Jellyfin server using Infuse, but only if I disable my system proxy first. What I want to achieve is to connect to my server using Infuse even without disabling my system proxy, which is what Jellyfin Media Player is able to do.

ok, that is odd if Infuse is using the same IP and port as the Jellyfin Media player is using. What is running the Jellyfin server? A NAS or a PC of sort?

The server is running on a Raspberry pi connected to an external HDD in my home network. Tailscale is essential in my setup because it allows me to access from remote networks.

And tailscale is also running on the Raspberry pi?

Tailscale runs on all my machines, with the Pi configured as the server and the rest as clients. It’s a private VPN that creates a virtual LAN from machines connected to remote networks.

I’m familiar with Tailscale, actually doing some beta testing for them on not yet released features. A little confused when you say that the Pi is configured as the server. This isn’t a client/server setup, all “clients” are nodes in the VPN mesh network.

What is the purpose of your proxy running on your iMac?

1 Like

This isn’t a client/server setup

Sorry, it is indeed as you said. I used this mental model to understand it since I thought of the Pi as an entry point into my home LAN from remote networks.

What is the purpose of your proxy

It’s a VPN I deployed on a VPS, only used by myself. I run it 24/7 because I frequently connect to public Wi-Fi I don’t trust.

I’m guessing you’re setting the proxy in this dialog, did you put in an exception for the IP used to access the Jellyfin server?

1 Like

I didn’t put in my Jellyfin server’s Tailscale IP in that box. But I think these exception rules should affect Jellyfin Media Player (the client) and Infuse in the exact same way, right? In other words, even though I did not put the server IP in the rules, Jellyfin Media Player has always been able to bypass the system proxy and connect via Tailscale instead.

I’m not one bit surprised that the Jellyfin developers program their own client to scan network interfaces to see if the client can detect a Jellyfin server:-)

Why not give it a try and add the local and tailscale IP’s in the dialog. There is no risk and only the upside that it might solve the issue.

2 Likes

Thanks, this method indeed solved the issue for me. (Sorry for delay, I was destracted by some IRL stuff and forgot to reply.)

Still, Infuse is the only app that had this trouble before I added the IP in the dialog. All the four or five browser I rotate between, Jellyfin Media Player and transgui were able to do it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.