Refresh Metadata not (completely) working

I renamed the genres of some of my TV shows on my Plex server. Infuse on Apple TV seems to refresh the metadata and display the genre changes just fine, but not Infuse for Mac.
On the Mac, new shows are added correctly, new artwork, etc, but the genres do not get updated. I tried going into Settings-Library and selecting “Update Metadata” manually, and also tried “Scan For Changes”, but it still does not update the genre.
Then I tried going into each TV show individually and selecting “Refresh”, and that works. Of course doing that for each show 1 at a time is cumbersome to say the least, so I’m guessing this must be a bug.

Apparently nobody else has noticed this?

I don’t use Plex so I haven’t noticed this specifically … but I can share that my habit if I’ve made major changes to the way I organize my files (changed folder names or filenames, updated significant amounts of artwork or metadata) has been to completely delete my on-device metadata, sync the deletions to iCloud, and then rebuild each device from scratch — not necessarily because such drastic action was necessary … but because it was a way of reassuring myself none of the old metadata would surreptitiously persist.

Generally though, just doing a refresh metadata ought to do the job. Issues with Apple’s background updating failing has made this less reliable; and the best way to ensure the refresh completes it seems is to turn off the AppleTV screensavers and sleep timers, and leave Infuse open to the Library page where update status is reported (perhaps overnight). Having a TV that lets you turn off the monitor without turning off the TV (so the Apple TV doesn’t also turn off) is helpful.

It actually works fine on my Apple TV. I was specifically referring to Infuse for Mac where there seems to be a bug with the refresh function.

1 Like

Ah, okay. Thought it might be related to the background updates bugs we’ve been experiencing lately.