Recommended Flash Drives

Worked : 512 MB Apacer
Did Not Work : 8GB Rallye

WORKED: 2GB pqi Intelligent Drive i810

DID NOT WORK: Sandisk Cruzer Mini 256MB

WORKED: 512 MB Memorex traveldrive
WORKED: 1 GB Freecom Data Bar

Worked: Kingston DataTraveler 1Gb

WORKED: Transcend JF V30/1Gb

SanDisk 128MB CompactFlash card using a Lacie card reader worked perfectly for me.

WORKED: Lexar “Jump Drive” 512MB Model: JDA512-00-501

This thumb drive is nearly 5 years old but, it worked.

Worked:

1GB Memorex Traveldrive

Did not work:

1GB Kingston DataTraveler
4GB GXT Mobile Disk

Your forum list verified usb drives and provides a link to a site where you can purchase them however, you cannot purchase them from their site and have to go into their store. The problem is that their stores are no where near where I am.

Can you validate that the following site shows the correct usb verified drive? Or provide another site where you can purchase them online? I don’t want to keep buying drives only to find out that they don’t work.

That is a U3 drive, and some people have had problems with U3 drives.

You can use this one:

this drive worked flawlessly for me

SanDisk 2 GB Cruzer Micro USB Flash Drive with U3

i did remove the U3 by choosing uninstall in the U3 popup on a windows PC first.

Memorex TravelDrive 1GB (usb2.0) works

Worked: Kingston DataTraveler 1Gb

Does not work:

Lexar 1 gb usb drive
PNY 1 gb usb drive
Dane-Elec 256 mb SD flash plugged into SanDisk MicroMate adapter

Any one else find any different please let me know.

Follow-up to my last post. I was able to get my hands on a Memorex 1gb traveldrive and the same thing happens when I install the usb drive and reboot appletv: either nothing happens when I reboot or it goes to the select language, select resolution and then Apple TV restore page. I am reformatting the usb drive as Mac Extended and running aTV directly from the disk image as instructed.

Just don’t know what I am doing wrong if anything.

FYI this is a new appletv…

The same with me…
The Kingston wasn’t wokring witt me…
And you tried the recommended memorex one without any success…

what can we do?? we paid 50 bucks for nothing at all??? and the support is just sending links to this topic…great…

Worked: Transcend JetFlash V30 1GB USB 2.0 Flash Drive (purchased at Target on 9/14/08) - I did use disk utility to “erase” the flash drive & used “Mac OS Extended” format. Do not name your new flash drive “aTV Flash” because you’ll be confused when you try to choose it as your drive. The disk image of aTV Flash has the same name. I learned this from experience!

Didn’t work (even after erasing & formatting to Mac OS Extended format:

  1. Dazzle card reader with Lexar 1GB CompactFlash
  2. Imation 128MB flash drive

(I got as far as formatting the drives and connecting them to the Apple TV, but I would get the text scroll and it would freeze before installation was complete)

Good Luck!

Did not work: PNY 8GB - I know, I know but I had it hanging around so you have to try, right?
Did not work: pqi Intelligent Drive i810 2Gb
Did not work: Kingston 1Gb
DID work: old, own-branded Staples 512Mb - not listed on Staples current site however.

Sony Micro vault 1GB works perfectly for me. cheers :smiley:

Imation Nano (2GB) works fine . . . and is the smallest flash drive I’ve seen. Dunno how to keep from losing it :slight_smile: