Recommended Flash Drives

Below are a few flash drives that have been confirmed to work on the AppleTV with aTV Flash. This is by no means an exhaustive list, and is only meant to act as a reference for those looking to purchase a drive for use with aTV Flash.

SanDisk Cruzer 4 GB USB 2.0 Flash Drive SDCZ36-004G-A11

Lexar JumpDrive FireFly 4 GB USB 2.0 Flash Drive LJDFF4GBASBNA (White)

Transcend JetFlash V30 - 2 GB USB 2.0 Flash Drive TS2GJFV30 (Black)

Kingston DataTraveler 4gb (violet) NOT WORKING!!!

Tomorrow I will try another Pendrive, hope it will work

 Sony MicroVault 8GB also not working!!!

I tried with these 2 flashdrives and I can't make it work!!! :( 

Sony seems to be ok for me so far. I did have some trouble with SanDisk Cruzer Micro. The best flash drives for me so far have been Corsair flash voyager and flash survivor. They are very sturdy and just dont break.

DID NOT WORK : San Disk Cruzer (older model), 1GB

DID WORK: Generic  (!) (Chipsbank 2091 on flash chip)

Can't open file either please help.

Can't open the atv Flash file they sent me please help.

Worked with Olympus 256MB XD Card, used my Camera as card reader...

CRUCIAL - GIZMO 8GB-ZML worked fine for me, bought from apple.ca

Alright, so getting quite annoyed. Bought aTV Flash Silver yesterday to install, and have tried 8 different makes and models of USB sticks, including a WD Passport, and none of them worked at all. Tried installing in different ports, different computers, and different OS’s. 

DIDN’T WORK:

ADATA C003 32GB

SanDisk Cruzer Edge 8GB SDCZ51-008G

Kingston DT108 16GB

Dane Elec 4GB

Lexar LJDS70 8GB

SanDisk Cruzer Switch SDCZS2N-008G 8GB (which works with aTV USB Creator)

Cheap 512MB USB stick I got from a Budweiser Stanley Cup Beer Case

WD Passport

Where the heck am I gonna find these “Recommended USB sticks” from almost 5 years ago to get this system working!? Anyone have any more current working USB sticks they can recommend?

Had the same problem with my Apple TV1 ignoring a couple of USB flash drives I had on hand–most disappointing was the 8GB one for which I had taken a considerable time to move the files to a hard drive.  So I searched for somewhere from which to buy one of the three confirmed flash drives James lists above in person–no luck.  Only online orders from Amazon.  So I went to Staples and found a SanDisk Cruzer Glide USB Flash Drive 4GB, model SDCZ60-004G-A46 for less than $7.  It was close to the one James calls out but it was not an exact match.  It came with some security software on it (not the U3 stuff), one executable file (RunSanDiskSecureAccess_Win.exe) and two pdf files within a folder.  I removed those three files and the folder, formatted the drive (FAT32) and ran the Windows version of the aTV Flash install.

This drive worked in my Apple TV1 on the first try and I’m up and running!

I have a sneaky suspicion that flash drives 8GB or larger may be causing problems but that’s only a hunch.

Anyway, there’s a currently available (as of September 8, 2013) USB flash drive that worked for me at a pretty reasonable price.

1 Like

I remember reading somewhere that you can burn a disc and plug a USB external cd/dvd to move the files instead of using a USB flash drive. Anyone know how to do that?

Is this still the case? I want to install aTV XBMC edition that released today to a USB drive and keep getting the same error: Process Failed, please try again! Tried more that 8 different model with no success! Shall I buy one of these or this is related to another issue?

My mistake! Instead of drag the Installer to the Application folder I was trying to run it from the Download folder! A bit misleading manual but I should have known!

so do u have to drag the app to the app folder then in order for it to work?

Yes, just like any other App. Then run it from there and try to install it on your USB. That’s it.

awesome i will give it a shot right now~\

I got an orange colored 512MB one from Office Depot for $7. It was branded with the Office Depot name. Purchased it June 2008 in NC.

hey,
just FYI, i used a new 2Gbyte Sandisk Cruzer ‘colours+’ USB flashdrive, successfully with aTV 3.2.

WORKED: 2GB Sandisk Titanium with U3 (Part #SDC27-2048). I had to remove the U3 software (available at u3.com).

DID NOT WORK: Sandisk Cruzer Mini 512MB