Recognize embedded subtitles tagged as 'forced'

Hello,

I’m using mp4box for adding forced subtitles on a DolbyVison single layer mp4 done with DVDFab.
I’m using this command:
mp4box.exe -add “MovieDV.mp4” -add “ForcedSub.srt#1:txtflags=0xC0000000:enable:hdlr=sbtl:tx3g:layer=-1:group=2:delay=0:lang=FRE:name=sub forced” -new “MovieDVWithST.mp4”

txtflags=0xC0000000 is the flag for forced subtitles for mp4 and Mediainfo shows the result file correctly as “forced”.

The problem is that Infuse doesn’t play it as forced, you have to select it.

Thank you for your help.

Regards,

Jmi91

6 Likes

Welcome to the forum!

Unfortunately, Infuse does not currently support the forced flag for embedded subtitles, but this is something we have on our radar to investigate further.

Why doesn’t it show forced subtitles automatically in any .mp4 video? I have them configured correctly, marked as forced subtitles with Subbler and they work correctly in QuickTime.

I use Infuse in Apple TV and iPad devices.

After a little digging it appears that currently Infuse doesn’t support embedded forced subtitles on mp4 files but I moved your post to a suggestion thread for that feature.

Don’t forget that you need to click the like button on the first post in this thread to show your support for this suggestion! :wink:

Good news, in 2019 Firecore was thinking of developing this capacity. It’s good that they haven’t forgotten it. Cheer up!

1 Like

And take a look at the number of likes supporting this suggestion on the first post. :man_shrugging:

I‘m waiting also for this feature for years :cry:

What are the proper subtitle settings for Infuse to automatically select subtitles with a default or forced flag in an MKV container?

Use case: I am watching a primarily English language movie/tv show with subtitled foreign language sections on an AppleTV. I have used MKVToolNix to flag the appropriate subtitle tracks as “Default” and “Forced.” Plex recognizes the forced flag. The subtitles are PGS format from Blu-ray rips.

In the Infuse AppleTV player, my settings are Playback->Subtitles->Forced Only and Language->Subtitles->Auto, but this still does not automatically select the default or forced track and I have to manually select it. Infuse recognizes the Default and Forced flags on the subtitle selection menu, but it does not automatically select them upon playback.

I have also tried Playback->Subtitles->Forced Only and Language->Subtitles->English, but this automatically selects the first English language subtitle track even on MKVs where there is not a Forced flag.

Any tips for settings that will force Infuse to automatically select the default/forced subtitle track upon playback of a file?

Welcome to the forum!

I don’t use subs often so I’m not real versed in how they all work with the different settings.

I believe that Infuse will remember your subtitle settings for a series once you set them on the first episode. Then when you play the next you shouldn’t have to re-select them. If I’m remembering correctly this worked for me.

I use subtitles all the time (I’ve killed my hearing riding around in planes for decades without protection). I usually select my external SDH.srt tracks when available, or English otherwise. Infuse remembers that choice, and keeps playing that same track until I select the other. I suspect if you play a (title).forced.srt track, Infuse will continue to play those until you select something different?

I am not using external SRT subtitles. I am using PGS subtitles that are inside the MKV container and which were ripped directly from the Blu-ray.

The MKVs include multiple English subtitle tracks, but I only want infuse to automatically play English language tracks that are flagged “Default” or “Forced.” So far I have not found a way to accomplish this.

Playback->Subtitles->Auto and Language->Subtitles->Auto does not automatically select the flagged default track even though, intuitively, it should.

Playback->Subtitles->Forced Only and Language->Subtitles->English will automatically select the forced English track on files with a forced English track, but it will also select the first English track on files where there are not any forced English subtitles, which is infuriating. This setting should only automatically play Forced English tracks.

I have never come across this. I only use forced subs and only ever see any subtitles if there are forced subs.

I do however have
Language > Subtitles left on auto so May be worth trying that.

1 Like

I tried using Language->Subtitles->Auto, and Infuse did not automatically select the forced English track.

Maybe can you post a media info of one of your mkv? I don’t think infuse looks at default. Only forced flag. I also don’t have issues with forced or not forced.

Blockquote
Text #2
ID : 6
ID in the original source medium : 4608 (0x1200)
Format : PGS
Codec ID : S_HDMV/PGS
Codec ID/Info : Picture based subtitle format used on BDs/HD-DVDs
Duration : 14 min 56 s
Bit rate : 3 125 b/s
Frame rate : 0.056 FPS
Count of elements : 50
Stream size : 342 KiB (0%)
Language : English
Default : Yes
Forced : Yes
Original source medium : Blu-ray

Did you ever find a way to get “default” tracks to play?

Hello!

I’m running Infuse 7.7.2 (4781) on an Apple TV 4K A1842 on tvOS 17.4. Infuse is pulling from a Plex library.

In Infuse, I have subtitles set to ‘Forced Only’. This seems to work exactly as expected for movies.

I have noticed that for TV Shows where some episodes have Forced subs and others do not, Infuse will auto-select standard non-Forced subs for episodes without Forced. If I were to then disable the standard subs in the playback menu, Infuse will remember this decision for the next episode and not show any subs, even if that episode has Forced subs. What this leads to is a per-episode process where I have to either disable regular subs or enable Forced subs. Plex does not seem to have this issue.

I tested this on Better Call Saul Season 3, episodes 4-8. They are alternating episodes with and without Forced subs. Ep4 begins with forced subs, auto-selected. Ep5, without forced, then shows regular subs. I disable these regular subs. Ep6, with forced, then starts without forced enabled. I enable them. Ep7, without forced, then shows with regular subs. Etc, etc.

I have tested the direct relationship between me disabling standard subs in one episode causing the next episode to also disable forced, and the reverse as well.

I have checked the flags on the embedded subs. Forced subs are marked as ‘forced’ and ‘default’. Standard subs have no such flags.

I think this is an issue with Infuse trying to play ‘something’ when other episodes have used forced subtitles. I don’t think there’s a problem with the logic of remembering generic subtitle decisions across a show - that makes sense to me. It’s that Infuse is selecting standard subs when previous episodes have shown forced subs that doesn’t seem right to me. Plex does not show the same behaviour of selecting standard subs in place of forced ones.

Infuse is not currently able to recognize forced tags for embedded subtitles, as there are limitations in the underlying libraries Infuses uses to process tags such as these.

You can follow this thread for updates.

Ah ok, so despite the subs showing themselves as ‘Forced’ and ‘Default’ in the Infuse player, because they’re embedded SRTs in an MKV nothing is actually done about those flags? That’s interesting, because surely that would mean I would’ve seen the same problem in movies, where the embedded forced subtitle track isn’t selected? Seems to work fine in that case, both embedded SRT and PGS. Am I getting that right?

A little disheartening that the linked thread was opened in 2019 and has otherwise been mostly dormant. In any case, I’ve added my like to the OP.

I’ve done a little bit more testing on a couple of MKV files with either PGS or SRT subtitles, and I don’t totally understand how this is an issue with Infuse not recognising the forced tag for embedded subtitles.

For embedded PGS, on a TV show, it seems to work fine:

  • E01, with only standard subs, shows no subtitles.
  • E02, with forced flag set on forced subs, shows forced subs.
  • E03, with only standard subs, shows no subtitles.

For embedded SRT, on a movie, it seems to work fine:

  • Movie has embedded SRT with ‘default’ and ‘forced’ flag set. Forced subtitles are shown.
  • Movie has no embedded forced SRT. Standard subs have ‘default’ flag. No subtitles are shown.

This, to me, suggests that Infuse can understand the forced tag on embedded SRTs? The decision to show forced subs must be based off the ‘forced’ flag in these cases.

The issue seems to exist solely for TV w/ embedded SRTs.

For embedded SRT on TV:

  • E01, with forced subs with ‘default’ and ‘forced’ flag set. Forced subtitles shown.
  • E02, with standard subs with ‘default’ flag set. Default subtitles shown.
    I disable standard subs in the playback menu since I don’t want full subtitles
  • E03, with forced subs with ‘default’ and ‘forced’ flag set. Forced subtitles not shown. It seems the setting I made to disable subs on the previous episode has persisted to this episode

For external SRT on TV:

  • E01, with forced subs named E01.eng.forced.srt. Forced subtitles shown
  • E02, with standard subs name E02.eng.srt. No subtitles shown
  • E03, with forced subs name E03.eng.forced.srt. Forced subtitles shown

The issue, from my point of view, is not that Infuse can’t identify forced subtitles from embedded SRTs - it seems to be able to? It’s that subtitle decisions (show/don’t show) are made season (or maybe show) wide - if subtitles are enabled in one episode, they should be enabled in all episodes. This feature makes sense - if I was hard of hearing or preferred subtitles on that particular show, I’d want to set and forget.

The problem is that there seems to be no differentiation between forced vs standard when making this decision. Since I have forced subtitles enabled globally, for shows where an episode has forced subtitles, Infuse decides I want any subtitles for the other episodes. Therefore for episodes with forced subs, it shows forced subs. For episodes without forced subs, it shows standard subs.

I can extract embedded SRTs no problem - I’ve already written the automation. But I really don’t want to do this. It creates more files, and I lose the nice MKV metadata tags for things like SDH, commentary, forced, etc that can be put on subtitle tracks. The result is them not displaying quite so nicely in Plex and Infuse (“is this subtitle track for the show or the commentary track?”).

@james I’d really appreciate you clarifying a bit further. I’m not trying to question you - you understand Infuse far better than I do. I’m just saying my testing doesn’t line up with what you’re saying. Could there be something else happening here?