Recently Added Movies Not Apppearing

First off let me say this app is the greatest ever made! I don’t know what I’d do without it as a movie aficionado =)

I’m using the latest Infuse 4 on my aTV 4th gen and up until a few weeks ago the “recently added” movies category worked flawless and sorted my movies from newest to oldest.

Now (even after updating library, which even does this on it’s own upon launch) the same subset of movies added a month ago shows up in the hierarchy (the new entries aren’t sitting in the “other” category either).

I’ve even tried restarting the box with no success. Any help is greatly appreciated and thanks so much for your valued time!

Seems a bit odd that I didn’t receive a response. Was there something I didn’t express or articulate in my previous post? Or was this a small issue that went away after an update?

A heartfelt thanks for any help or guidance =)

Version 5 is comming soon

Library view has never worked properly for me. Was unaware v5 was coming though! Maybe that’ll solve it.

But agreed. The app is amazing, regardless.