Recently added - Library vs Share

Up until now, I have my media divided up into 3 favourited folders stored on a NAS, accessed via SMB. I view by Date, so all the stuff I add sits at the top of the list. When I use the Library view and browse by Date Added, the order is completely different. Movies I added last year are appearing at the top of the list.

Any ideas?

This is somewhat expected, as the sort by date is the date Infuse first indexed the videos. So if you’re setting up Infuse for the first time, all your movies will be indexed on the same day and it will likely end up listing them in reverse alphabetical order.

However, movies you add in the future should appear at the top, as expected.

Sorry - I’m a bit confused. I’m not setting up Infuse for the first time… Or does the Library view reindex everything?

Since buying Infuse for the ATV4 I’ve always viewed files by date, so every time I add a file to a share it appears at the top of the list. Shouldn’t Library view see everything the same? Or am I missing something?

Def not working as I expected.

  1. Only fav are part of Library and that is mandatory…

  2. Indexing of Library is separate from any actions on Fav…so watching and/or deleting something in Fav, does not automatically update the Library…you must scan again.

The two especially together seem counter intuitive…

So basically, if you add something to your drive and want to watch it ASAP, you must do via the Fav as re-scanning can take a long time depending on your Library size…silly really.

The indexing of items is the same, though with the release of 4.2 Infuse now includes a few automated steps that previously were only triggered when navigating to the folders. The completion of these extra steps ‘complete’ the indexing process for a particular movie/TV show, so it’s possible Infuse had not fully indexed the content when using 4.1.

Library info is cached for performance, so changes will require a scan to take place before they’re picked up.

You can trigger a manual re-scan by tapping the ‘Last Update’ text in the Library menu, or through the Settings > Library menu.

OK, so this still isn’t working properly for me. When I browse to Library View, and look at recently added, it shows a couple of things that are recent but loads of stuff that I added post 4.2 isn’t there. Is anyone else having this problem?

What type of content? Movies, TV Shows, home videos?

If you navigate to the Settings > Library menu, when does it show your Library was last updated? Any errors listed there?

My library was updated 1 day ago. Here is a screengrab of my NAS share - in order of date added…

When I browse to my ‘Films’ favourite and view by date added, I see this, which pretty much reflects whats in the screengrab.

But this is what I see when I browse to library and view Recently Added. Some of the films its displaying were added over a year ago.

Any ideas?

Thanks for the info.

The upcoming 4.3 update (coming soon) may help with this.

Thanks! In case it helps…

Synology DS214Play. Connecting via SMB.

This still doesn’t work for me… I’m happy with using different folders and browsing by date added, but thought I’d let you know.

Same problem here with Infuse 5.1 Pro.

On my favorites folder the sort order by date works and the newest movies are on top.
But when I go into the library view on recently added it looks like a reversed alphabetical order of my movies. And it is the same sort order as on “all movies”. I also added some new movies a few days after the installation but they don’t show up under recently added. The library was updated as stated in the settings menu.
That all makes no sense an is not usable!

I have been having this same problem since i upgraded to 5 pro a few months ago. My movies used to sort by date when i added them to the my share drive through infuse 4 pro. Now when i sort by date it puts it in what appears to be a random order. A lot less convenient than it used to be. I just decided to search the forums for a resolution. It appears this thread is discussing my issue. Any progress on this?

Still not working. The whole library thing is useless for me.