Recently added films in home screen

Hello there,

Have two ATV 4k with latest TVOS and latest Infuse 7 Pro with identical settings. Movies are on the NAS, all connected by the wire. Also have same Infuse 7 Pro on my mac studio, also wire connected. And on TVs the Recently Added Films in main menu behaves as it wants and when it wants - refresh of the added items may happen once a month or even in three months, or can be updated next day. And the items, which appear may be different on two ATVs, some films appear on one, but not on the second, some on both, some do not appear at all. On the other hand Infuse on the mac studio works as swiss watch - an item added to the NAS immediately appears in the Recently Added Films. Settings of Infuse on mac are the same as on TVs. Would be nice to have an idea what goes on? I’m doing something wrong or this is some fault (or strange design feature) in TV version? Thanks in advance.

First, what version numbers of tvOS and Infuse are you running? Beta tvOS or release version?

One setting that has a lot to do with how well multiple ATVs stay in sync is the “Background App Refresh” in the ATV settings. First, make sure it’s set to “On” and if you want to really optimize the settings for Infuse to stay updated you need to turn off as many other apps as possible so Infuse gets the most time allotted to update in the background.

When you go to the Infuse settings “Library” page, what do you get for the last iCloud sync and what do you have for the Last Updated message on the left side of the screens?

In my many years of experience with infuse, this has always been, as a Vaskorn described it.
I kind of accepted it. But it never worked as it should.
Even if a new movie is shown in its share etc. It might not be shown under recently added.
The background refresh is set to on.
In infuse in library setting it says permanently “synchronize with iCloud” and the wheel is spinning.
Now it says, getting content from nas. After a while it says, not possible, although the nas is switched on, and the shares can be accessed.
Now, after leaving the library settings, and going back, it says last update today 19:09, which is the uptown date time.
In the recently added view there are some new movies mixed with older entries of movies. I mean really old ones. Several years old.
I don’t know, if that is helpful.
Anyway, it always behaved like this.
That’s why I’m working based on shares and not with the library or other folders.

And one last thing. Didn’t you give the advice to switch the background refresh to off, when there is the problem, that after a software update , it takes a lot of time to reinstall the library ???

I never use betas, it always latest Firecore update without my interference. Sure will check Background App Refresh, thanks. I do not use iCloud, everything goes from my NAS. Library update was made in a manual mode, and of course it shows the date when I make update. Thanks for reply.

In some minutes had checked everything. Background App Refresh was ON. All possible refreshes were done, figures confirmed modern refreshes and updates. NAS and ATVs restarted (actually I made before and not one time). Same result - both ATVs have same old (on one - about week old, on the other about three weeks old) and different :slight_smile: list of Recently Added Films. And Infuse on mac perfectly reflects yesterday added items.

Thank you, now I know, that it’s not my stupidity or curve hands :slight_smile:. From the other hand, if it’s possible to make Infuse work in a proper way on mac, why not on ATV? Question is, of course not to you :slight_smile: but to Firecore.

Hi vas, I am not planning to go on interacting in this forum.
I feel, that my questions and problems were not treated in an adequate way in recent times.
So I hope, that they will be able and willing to find a proper solution, or at least an honest answer.
Personally I prefer, if people admit, that they are not able to solve a problem , at least for the time being. Rather than telling me, that I am doing things wrong.
So, good luck :slight_smile:

What type of device are you streaming from?

Is the same connection method being used on the device(s) you are seeing differences from?

Do you have the same ‘Sort By’ option set in Infuse > Settings > General on all devices?

Dear James,

Thank you indeed for quick reply. I’m streaming from a recent ( and powerful enough) Synology NAS. Connection of both ATV 4K and Mac Studio is Gigabit Ethernet distributed by Apple Extreme Airport devices. ‘Sort By’ is ‘by Title’ on all. Actually, despite the fact, that this is (Recently Added function) may be not the main thing in the system, but being there is really useful and welcomed. And working in a wrong way (more honest to say ‘not working at all’) is really disturbing. Especially keeping in mind, that it works perfectly on Mac, which I do not use virtually at all, and not on ATV 4K, which I use on daily basis. Also it appears quite intriguing, why it works differently on two ATVs - both show different items (some may be the same) and with different time of updating, if ever. Updating on ATVs may vary in time (some days to some months), variety and order. I guess I’ll be not the only one, who will be very pleased to see this unpleasantness solved.

P.S. All setting (not only ‘Sort by’) are identical on all devices.

Hi Gram, well… actually Apple is known for not recognising obvious problems for years, as it was, for example, with ATVs being not able to reproduce 24.000 correctly. Firecore is not Apple, but, as a very close cooperating company, looks like also a little bit infected by this disease.

Well, I think they are dancing on too many weddings, as we say in Germany.
It was much better years ago. I’m a long time user.
But now moved to another system, which suits my needs much better.

We are in the same boat. On my opinion things were starting going worse when purchase possibility was taken away and all were forced to subscription. Tried other systems, was not satisfied, something better, something worse. Counting, that I have a lot of Apple devices, returned to using Apple with Infuse. All in all, it is still better, to my taste :slight_smile:. So let’s see…

I’m an total apple user as well. Since ages.
For my homecinema I changed to Zidoo, which has all the features I need, like full atmos, 3D picture, picture Parameter adjust. Also, the posterwall is way better organized, than infuse, and looks pretty cool, as well.
And recent entries works perfect :wink:

Disadvantages are, it can’t sync several boxes, and the boxes can’t do streaming from Netflix etc. Therefore I keep my atvs, and maybe infuse as well. Just to play around.
But I won’t proceed with any discussions here in the forum.

Exactly Zidoo was what I tried for about a year. Sold and got latest ATVs as soon as Apple fixed 24.000 problem, as I have a lot of French, German and Italian films, which are mostly 24.000. But looks as we are going offtop :slight_smile:.

Right. I wish you much success here.
I will follow, silently :wink: