Random mp4 files appear

Random mp4 files are appearing in my library which is annoying. None of these are on my drive which holds my files. They are named random like $R264L41.mp4 for example. I can not delete as I get an error message. What are they? I set up a new hard drive today to hold my files so nothing else is on it

Welcome to the forum!

Are you by chance connecting via a DLNA or UPnP connection?

Also, what device are you using? ATV, iPhone, etc.?

In settings, do you have “Show Filenames” On or Off?

I have an external drive plugged into my pc that I have shared.
It displays the strange files on both iPhone and appletv and also on my MacBook Pro

Show file names is turned off

Again, what protocol are you using to connect to your server?

DLNA, UPnP, SMB, FTP, ect.?

It’s SMB

Can you provide a screen shot in Infuse where you’re seeing this and possibly a directory screen shot on the server in the folder it’s showing up in for Infuse?

With symbols like the dollar sign and others it may be a server thing. What OS on the PC?

I am using windows 11 on the Pc. This is how infuse is showing on my iPhone. As you can see there are those random files at the beginning. There are about 6 in total. Screenshot is at the link https://1drv.ms/u/s!AulZTOKft2sajvg5qHYQbeAX_aRYEg

A directory screenshot shows just the films I have those random files are not present in the directory

Do you know what directory those mystery files are supposed to be in?

Windows may be creating them for some reason and marking them invisible to the pc but not to Infuse. Do you have the PC set to also run as a DLNA server?

That’s usually when the odd names appear when there’s a DLNA or UPnP server running.

Can you figure out what directory their in and then see if they are invisible files to the pc?

Hi no the pc isn’t running as any kind of server and I only have one directory on the external drive for the movies. All I have done is to share the drive via windows properties. The only files visible are the ones that are supposed to be there with show all files selected. If I click on the film categories none of these files show in any of them only on the main infuse screen. So for example I select Action and so on I see what I expect to see

Can you sign into the PC with the MacBook like you were going to share files and find these files in the Mac finder? They are there somewhere on the drive.

Also you may want to try doing a refresh metadata in Infuse by going to settings > library and scrolling down to the bottom on the iOS version.

On the Mac it also only shows 66 files which is correct. It’s the 7 other as shown on the infuse screenshot which are the issue as these 7 are not physically on the drive

https://1drv.ms/u/s!AulZTOKft2sajvg6EZmeRMBHb4mGFg

The trick is going to be finding where those are. Since you only have 66 files have you tried starting fresh? That shouldn’t take long. Delete the metadata and let it start again.
Go to Settings > General > and at the bottom you’ll see Metadata with a size next to it and a trashcan. Trash it and let it rebuild?

Edit to add, I even try deleting the share and re adding it if the above doesn’t work.

What do you see when you touch the folder at the bottom of the screen?

Do you have show system files turned on? Files that have $ in front are usually created by windows. These files are usually lock files that are created by some program or process within windows. Infuse won’t create these files. You might be able to track down what’s creating these files with sysinternals tools.

1 Like

I ended up deleting the share this evening and adding back and those files no longer show. Puzzled as to what caused them.
Thanks for your help

1 Like

Thanks for the follow up! That was a strange one. As @JarvisMeier said, often those type of files are associated with the OS with the “$” but hey, as long as your exorcism worked we can count it as a win. :wink:

This looks like it may be a similar issue.

Are you using any ‘illegal’ characters in your file or folder names?

Ilegal characters include: / ? < > \ : * | " (and any character you can type with the Ctrl key)