Random micro stuttering

Ok, so Infuse has been working great on my ATV4K forever, but the last few days I have seen random micro stuttering show up on everything I watch.

I have not changed anything in my setup. The ATV is set to match frame rate and this has worked perfectly. The TV still reports the correct frame rate. It is definitely not the source material because if I rewind and watch the very same passage again, the stuttering is not there.

Is anyone else noticing this? I can’t stand micro stuttering!

I’m running Infuse Pro 6.3 (2932) on ATV4K tvOS 13.3.1.

Is this affecting all files or just a few?

We have a 6.3.1 update waiting approval at Apple with a handful of improvements which may be worth a try once it’s out.

Seems to affect all files I’m playing. It’s very inconsistent though.

I have the same problem.

Thank you! It’s good to know I’m not alone.

Please give today’s 6.3.1 update a try and see if you notice any change.

Also, you may double-check to ensure the Playback Speed option in the main Settings menu is set to Normal, and not a faster/slower speed.

Thanks, James. Playback speed setting is set to normal. 6.3.1 update is not available yet for me. I’ll be sure to check it out as soon as possible.

Still present on 6.3.1 I’m afraid.

Is this affecting all files, or just a few?

Would you be able to upload a sample we could review here?

It seems to affect all files. However I’ve only been watching 23.976 fps files recently and haven’t done any testing with other frame rates.

Sure, I’ll upload a file where I noticed this stuttering when I get back home.

Maybe this was introduced with the latest tvOS update, I’m not sure. It’s very inconsistent so it’s not easily detected but since I’m overly sensitive to the phenomenon I see it a few times per episode I’m watching.

I don’t want to derail what James is thinking but I’m curious as to what apps are enabled on your ATV for the new background updating feature. I noticed on my setup that there were several that I really didn’t care to have taking up background tasking so I turned them all off except for Infuse. It almost sounds like the processor is not quite handling the multitasking and is occasionally shorting the playback processing in Infuse.

Interesting. I didn’t even know about this feature. When was it introduced? I’m gonna go look for it in the settings and I’ll definitely disable all apps but Infuse.

Edit: Found the setting and disabled four other apps including an IPTV app that I know for a fact is resource heavy. Keeping my fingers crossed that this is the issue.

I’ve uploaded an episode now, James.

Please do let us know if this has any impact.

If the issue is still present afterwards, would you mind sending in a report from your device (Settings > Submit Diagnostics) and posting the 5 digit code?

Also, can you double-check just to ensure the Match Content options are enabled?

Match content options are enabled. First tests after disabling background updating for everything except Infuse are positive, problem seems eliminated. A bit early to say though, since the problem was so inconsistent. I’ll do some more testing and will let you know.

I believe turning background updating off for all apps except Infuse has solved the problem with the random micro stuttering I experienced. Thank you very much to NC Bullseye for suggesting this solution!

For now, consider this problem solved.

Thanks for letting us know! If you ever get bored and curious maybe you could add the other apps back one at a time alone with Infuse and see if there’s an evil app that others could avoid. :slight_smile: Again, thanks!

I might just do that at some point! :slight_smile:

I know it’s a pain sometimes. One thing that may help though is if you could provide a list of apps that you turned off. Either post them here or you can PM them, either is fine. :wink: That may help figure out the process hogs out there.

Of course! The apps that I deactivated are:

iPlayTV (IPTV app)
Sveriges Radio (Swedish radio streaming app)

Out of these four I’m fairly certain iPlayTV is the culprit. It indexes over 20000 IP TV channels regularly and I bet that can be pretty resource heavy.