Random artwork being shown ATV4 and iOS despite both tvdb and themoviedb having the CORRECT artwork for scraping

Hello, odd issue here which has not been addressed before I think (Couldn’t find on search).

The SAME issue occurs with both ATV4 and iOS (iPad Mini 2) for me but I’m not sure where the issue lies (app/server/db/scraping etc).

Here is my ipad showing some of my documentaries. The ATV4 exhibits the same images:


Note the arrows. The red arrow points to The Blue Planet. Named correctly and all info scraped correctly APART from the artwork which shows a wave. Where did that come from? If you look at both themoviedb AND tvdb, the only images they should be serving are these (the top three from themoviedb and everything on tvdb don’t even have the wave image to serve):


…but it gets worse with the Dinosaur Planet series. Look at the yellow arrow. Note, the artwork is in German for a start. Note also that “die letzten jahren der dinosaurier” means “The last days of the dinosaur” in English so it isn’t even showing artwork for the correct show.

The correct images from both tvdb and themoviedb are meant to be these:


So WHERE on Earth is Infuse scraping this random image from? Why is it applying it to a different language, different show item?

I have cleared the cache, refreshed metadata again, rebooted both ATV4 and iPad, made sure it’s all named correctly, removed hyphens, put them back, removed apostrophes, put them back, named the files every which way you want, renamed the files as per tvdb and moviedb correct titles…whatever I do, Infuse insists on serving up THE INCORRECT IMAGE.

I’ve even tried adding the correct image in order to override it manually, thus:


…I have tried the using both the name “folder.jpg” as well “Dinosaur Planet.jpg”, both to no avail. I keep getting this stupid image instead of the correct one from I know not where:


The issue isn’t that Infuse cannot serve an image, it’s that it sometimes serves a random image that it couldn’t have gotten from the movie/tvdb’s because they don’t exist there…so Infuse appears to randomly pull images out of the cosmos and serve those instead!!!
Where and what is Infuse scraping to get it’s metadata? It must be searching other sites in addition to tvdb and themoviedb…why?

How do I get Infuse to serve correct artwork for ALL my files because they are all labelled correctly as per metadata 101 guidelines and the names on themoviedb and tvdb and yet I’m still getting random ones appearing out of nowhere that I can’t even correct using the “manually override artwork” instructions.
Also, why won’t manually overriding the artwork work anymore? Has this ability been removed from Infuse?

Can anyone shed any light on this please?

Do you by any chance have “Embedded Metadata” set to “On” in the Infuse settings?

If yes, then it is possible that Infuse is getting the image from the video file itself.

I have Infuse set to getting metadata online NOT locally.
(i.e. not using embedded metadata)

Have you tried updating to the latest version of Infuse 5 to see if this is also an issue there.

I’m not sure where these images are coming from, but it’s definitely possible they are images embedded within the videos themselves, and Infuse could be using them if it’s unable to pull an image from TheTVDb. Embedded images would also be used if you have the ‘Embedded Metadata’ option enabled, even if you also have the Metadata Fetching setting enabled.

As a last resort, it is possible to override TV series and season artwork (requires v5.4.2 or later), but your files need to be arranged in a rather specific way. More info on this can be found here.

I have the most update Infuse on both iOS and ATV4.

Again, I have the embedded metadata option set to OFF and the fetch online metadata option set to ON.
I have also used 2 metadata tools (Usher and FilmTag) to strip all metadata from the files so there is NO image embedded in the files themselves.

As per my original post, I have named the files correctly using your own guidelines. Still happening. The folder.jpg trick works for most of my other TV series btw so I don’t know why it isn’t for these particular ones only.

Could it be a problem with tvdb or moviedb?

Based on your screenshots, it looks like you’re running something other than the latest - maybe even v4. Can you check the version you are using? This can be viewed in the sidebar menu (or via iOS Settings > Infuse).

There were some API changes earlier this year at TheTVDb, and while these were not critical at the time it’s possible they are starting to change how/if they allow old APIs to be used…which could cause issues fetching artwork like this if you’re not using the latest version of Infuse.

Ah, yep, sorry you’re right, it’s Infuse 4 (but the latest version of that - so on the iPad it’s Infuse Pro 4.3.7, my ATV4 is also updated to the latest version of 4). I also have a TRakt account and am connected to that as well.

Still don’t know why 90% of my media scrapes correctly and these ones don’t. Or are you saying I have to have 5 to work properly (in which case I’m happy for you to give me a free upgrade ;)). Seriously though, the app should still work correctly and isn’t. I’m thinking if it isn’t Infuse, it might me the db’s themselves. I just tried to go onto tvdb and they’re down for maintainence - could it be the app is asking for the correct artwork and being served incorrectly on their side?

I just did a quick test in 5.6.3 (using your same filenames) and things seem to work as expected, so I don’t think there’s an issue with either database. See attached.

You can try using the Edit option and reselecting the correct title to see if simply refreshing the artwork for these videos changes anything.

Well that illustrates my point, you aren’t receiving the correct artwork either. The Blue Planet should not be a wave but a picture of a shark against a blue background as I mentioned in the OP. This indicates an issue on the tvdb server end (maybe when they went down for maintenance something broke?).
OTOH, you ARE getting the correct image for Dinosaur Planet which indicates that folder is an issue at my end - maybe in a .store file or something either on the media drive or in the ATV.

I have used the EDIT option to attempt an artwork refresh but it doesn’t work, Dinosaur Planet is stubbornly stuck on the German artwork for a different series altogether.

I’ll keep searching for an answer.

That particular artwork is the season level artwork (https://www.thetvdb.com/?tab=season&seriesid=74372&seasonid=7343&lid=7) that was top-rated by TheTVDb at the time it was fetched. This may be due to the fact that the ‘shark’ artwork only has a single user rating. The top rated artwork will change from time to time based on user ratings.