Question about audio output

my understanding from reading these posts in this forum is that I should be getting PCM for audio output.

right now everything (DD, DD+, DTS, Atmos etc…) is showing as audio output 5.1.2 ch Dolby Surround on my Onkyo RZ820 receiver.

My receiver is connected to my LG Oled TV via input 2 ARC and my Apple TV is set to Dolby Atmos which I am getting fine with Netflix and Apple Movies, saying that I am also getting output 5.1.2 ch Dolby Surround for any other audio other then Atmos so something does not make sense to me.

Sounds like you have the ATV set for 5.1 in the settings. If so, try auto instead.

Just to clarify, if you go to settings > Video and Audio > Audio Format > Change Format should be off. Your other options here are Digital Dolby 5.1 and Stereo.

Yours is probably set to 5.1 here. Turn “Change Format” to off and see if that gives you what you want.

There’s a users guide that can help you with the settings here https://support.firecore.com/hc/en-us/articles/217735707-Audio-Options-tvOS-

Your receiver might also be set for Dolby digital surround which will upmix everything sent to it.

Remote MOVIE/TV button.

Looked at the manual for the op’s receiver and this may be the culprit too. Your receiver may be scaling everything.

Good suggestion!

Thanks for all the info!

I could not find any settings on my receiver that set the default to Dolby Surround, saying that the culprit was the MOVIE/TV button - by selecting this I was able to switch to Dolby Digital. I am now getting DD for INFUSE, Netflix and Amazon ion my Apple TV. (or DD+ directly on my LGTV Netflix and Amazon apps - I was under the impression DD+ was available on Netflix Apple TV but that is not a deal breaker for me)

Strange that I am not getting PCM - but at least I am getting DD (see attached) … so I checked my Apple TV settings and my audio options are set as follows:

  • change format - OFF
  • immersive audio - Dolby Atmos ON.

I am OK with this setup on my ONKYO receiver unless I am missing something else. ( only minor nuisance is that now there is a lot more audio switching which creates a “click sound” on the receiver from the audio input changes).

One note, if you are using ARC from your LG TV, then the Apple TV will send audio as Dolby Digital (up to 5.1 channels) instead of lossless LPCM.

Infuse will adjust to handle this automatically, but the only way to get true LPCM (up to 7.1 channels) is to connect the Apple TV directly to your AV receiver.

Thanks for that info James!

I can easily do this but before I do (and adjust all my Harmony One commands) , and this is subjective but is PCM that much better then 5.1.

Well, it depends…

If your source material is 5.1 Dolby Digital/DTS, then you aren’t really losing anything with your current setup.

If you are playing a lot of 7.1 TrueHD/DTS-HD MA files, then yes there would be a difference. Whether you notice this or not will greatly depend on the person, and the type of speakers being used. There are quite a few discussions on the web regarding this topic and the opinions range from ‘no difference’ to ‘night and day’…so YMMV.

just a quick update - I connected my Apple TV4K directly to my receiver and from what I can tell there still is no LCPM option, unless the Direct option is LCPM
Here are the audio options I have with INFUSE:

DTS: Neural X. — I am testing this compared to DD when my Apple TV 4 was connected directly to my TV
THX Cinema
Dolby Surround TV Logic
All Channel Stereo
Full Mono
Theater Dimensional
Direct
Multichannel
Dolby Surround

Try direct.

“Multichannel” this is LCPM.
Direct this is raw not calibrated sygnal.

What do you want to achieve? My advice, is you wanna play movie and oryginal sound is DD\trueHD\atmos set in avr Dolby Surround if your sound file is DTS\MA set DTS: Neural X or keep Multichannel.

And btw syginal from atv4k not have name lcpm but “multich PCM”

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.