QMS/Match Content (adjustable Delay) Fix

That’s some magic then. Infuse can’t even pull anything off my local NAS instantly, even while its spun up.

I’ve never noticed any issues in the above situation, but I can’t deny you two certainly do.

Exactly!
Infuse add a „Waiting“-Screen in every Case, even if the Output matches the file Framerate! So it’s definitely a global issue, not only about QMS!

(I was able to edit the Thread Title :wink::+1:)

1 Like

On my Network it’s also playing instantly without any buffering :sweat_smile::+1:

1 Like

I have modified the first Posting in this Thread a little bit, so it should better describe our Problem with MatchContent/QMS and that we need an adjustable Delay-Setting for this :wink::+1:

1 Like

As a new user of an LG C3 TV, I’d love an option (or automatic detection if possible) to remove this black screen.

TVs with QMS support are still very new, but this feature is presumably coming to more TVs in the future, and tvOS seems to enable it by default when it detects its available.

2 Likes

MrMC allows you to adjust the duration of this black screen in settings. I’d love for Infuse to have this too, so power-users could adjust it to match their TV. And so those with QMS TVs could set it to 0 seconds.

2 Likes

Yes this is absolutely needed! Currently Infuse is taking still 4 Seconds to change the Framerate, even with QMS-compatible TVs, and that is a real bummer :+1:

2 Likes

Just commenting again to clear things up:

Infuse appears to be adding a short (3-4 second) black screen before starting a video when frame rate matching is enabled. This makes sense. However it’s not needed with devices that support QMS, since QMS devices can switch frame rates instantly and don’t get the “HDMI bonk”.

Yes, it’s just a short black screen. It’s not a huge deal. but a smooth UX is the reason I have an AppleTV and use Infuse. Infuse also has a good history of supporting the latest formats where possible (such as Atmos and Dolby Vision profiles and even Content Matching when tvOS first added it) so I think QMS is just one, newer, piece of the puzzle.

It’s especially annoying when starting and stopping many videos to find one you want to watch (anyone with young kids will know this happens a lot, lol). It makes Infuse feel slower to load SDR videos than every other app on my AppleTV.

I think a good solution would be :

  1. Automatically detect (if possible) that QMS is enabled, and do not display this black screen when it’s not needed, or

  2. An additional option in the UI to disable this black screen. Or to set its duration.

The HDMI blackout still occurs when switching formats (SDR, HDR, DV etc) but I noticed that my LG C3 TV can do it in around 2 seconds, not the 4 seconds which Infuse enforces.

Thanks!

3 Likes

Yeah, I also noticed the black screen delay on Infuse, and it’s annoying since the Plex player plays it instantly while the qms is on.

We really need an option to adjust that on Infuse. I’d really prefer just an option to disable this black screen altogether, independently of qms, because even without qms, infuse is slower than plex due to that feature.

FYI: The Samsung OLED S90C sold in Brazil is also compatible (without any firmware update). You just need to put the tv Game Mode on Auto and turn on the qms option on the atv.

3 Likes

Yes this Screen is really annoying :pensive:
I have the same Problem with my Sony (even if it’s not QMS compatible), because my TV is set to 4K, 50Hz Output and 25/50Hz Videos also get this annoying 4 Second-Blackscreen every time…

A simple Setting to set the Blackscreen-Duration (0 to 5 Seconds) would help us :+1:

@james This not take much Time to implement, but would help us a lot! This 4 Seconds-Blackscreen has been introduced some Time ago to get the Sound/Video in-Sync (during the HDMI Resync), but is not needed for QMS-compatible TV‘s and for Users which use 50Hz Output and 50Hz Videos in Europe (where no HDMI Resync happens)!

3 Likes

And 4 seconds is a very conservative amount of time, many TVs don’t need that long to change modes. My 10-year-old Sony TV only takes about 2 seconds to switch.

3 Likes