QMS/Match Content (adjustable Delay) Fix

(I open here a separate Suggestion-Thread for this)

The latest AppleTV and the latest LG-Televisions now support QMS VRR (Quick Media Switching) to avoid the long Blackscreen on Framerate-Switching.

It’s working perfectly, but there is a Bug in Infuse, which still show a 4-second „Waiting“-Blackscreen before playback of every video.

If Framerate Matching is turned OFF, there is no Blackscreen before playback. So we assume Infuse is putting in a „Waiting“-Blackscreen (4 Seconds long), as it waits for the TV to switch frame rates (HDMI Resync). But now with QMS this „Brake“ is not needed anymore!

But the problem is not happen exclusive with QMS! The „Waiting“-Screen appears even if we play a Video which exactly match the Framerate set as Output-Framerate of the AppleTV! (e.g. a 50fps Video with 50Hz output).

It would be great if this could be manually adjusted how long this „Waiting“-Screen appears (at the START and at the END). And with activated QMS we could simply set it to „0 Seconds“.



Have you tested this yourself?

1 Like

I have two confirmations that this problem occurs in Infuse (one here in the Forum from @J0E and another one from a Chat-Friend).

I’m using an Apple TV 4K 2022, with an LG C3 OLED TV.

I can confirm this is the behaviour I’m seeing, as Christian described.

Infuse is definitely inserting a black screen - the TV is not blacking out, it switches the framerate instantly as playback begins.

I’m seeing this behaviour with every SDR video I’ve tried to play in Infuse. Playing the exact same files using the Emby app results in instant playback with QMS, there is no black screen.

Playing an HDR or Dolby Vision video results in the TV blacking out for a few seconds to switch modes, as expected. This is demonstrated by the VRR Information menu going blank for a few seconds (whereas when playing SDR content, the VRR Information menu does not go blank, and immediately shows that the TV has switched to the correct framerate using QMS).

1 Like

So basically Firecore is accommodating the 99.9999% of Infuse users who do not own a QMS television and would otherwise miss the beginnings of everything they watched while their TVs switch over.

Got it.

Yes, a new menu option seems the simple fix (as I don’t know how detectable it is for an app in AppleOS to identify a TV with such a feature, but it doesn’t seem it would be allowed).

But you know how loathe Infuse is to add obscure menu options that most people (like the 98% or so of users who never visit here) would never use. :crossed_fingers:t3:

1 Like

I think I’m sure it’s possible for an App to detect if QMS is set to ON, and then simply show no „Waiting“-Screen (HDMI Resync) in this Case :wink::+1:

Because we done a Test:
If „Match Content“ is set to OFF, then no „Waiting“-Screen appears. This means that Infuse is able to detect whether “Match Content” is being set to ON or OFF. And then it is certainly also possible that Infuse detects whether QMS is On or Off :wink:

1 Like

Yeah I’m really hoping this is the case. That would be a nice easy fix for the developers, and wouldn’t introduce any confusing menu options.

Although personally I wouldn’t mind a menu option for this. I remember Kodi had that option, you could select how long this blackout screen came up for, which was useful for calibrating it to your TV. Infuse does a blanket 4-seconds for everyone, but some TVs can switch modes faster than this, so power users could experiment and adjust it to their particular TV.

1 Like

I couldn’t agree more :wink::+1:
A adjustable Blackscreen (at Start/End) would be the Solution for all Cases! And then simply set to „0 Seconds“ if QMS is used :+1:

1 Like


If Match Content is Off, nothing changes. If Match Content is On, then the HDMI connection gets interrupted. You figure Infuse is detecting the interruption? And could then detect the connection being restored?

Which comes first? … Does the AppleTV tell Infuse what the video settings are, or does Infuse just send its signal (per the content and its user settings) and let the AppleTV figure out which settings to switch to based on the signal and its user settings?

And since Infuse knows the video settings it’s outputting to the AppleTV, its simply inserting the pause whenever it switches from one output signal type to another?

The „Match Content“ is not directly a Feature from Infuse, it’s an global tvOS Feature.

But Infuse is adding an extra „Waiting“-Break at the Playback-Start to avoid a Video/Sound „CutOff“!
Because on some TV-Brands the „HDMI Resync“ is taking longer than on other Brands…

Something just occurred to me, so I did some more testing. This isn’t just an issue for those with QMS.

I disabled QMS, and set my Apple TV format to 50Hz (with Match Frame Rate still enabled). Now when I try to play a 25fps video, Infuse puts a blackscreen at the start, even though the TV does not have to change mode as it’s already at the correct frame rate setting (as confirmed by watching the VRR Information menu on the TV, and the fact that there is no blackscreen at the end of playback).

The same happens when the format is set to 60Hz and I play a 30fps video.

This suggests to me that Infuse is detecting that Match Frame Rate is activated, and always inserting a blackscreen at the beginning of playback, even when the TV doesn’t have to change modes.

It seems like Infuse isn’t aware of when the TV has to change modes, so always inserts a blackscreen just in case. I imagine this would be a harder thing to fix.

1 Like

But wouldn’t it do this just because it knows the content it is playing next is different from the signal it was sending previously?

Is Infuse told by tvOS what output mode the TV-AppleTV connection is in (and if “Match Content” is enabled), and edit its output accordingly?

Or does the AppleTV simply take whatever Infuse is outputting and either change its connection to the TV to match what Infuse is sending, or does the AppleTV convert whatever Infuse sends to the output mode the user set in the AppleTV settings (if “Match Content” is off)?

I think it’s intentionally programmed with the „Waiting“-Screen which generally happens…

But the best Solution would be a Setting to adjust the „Waiting“-Screen Time, so we can set it to „0 Seconds“ if we use QMS :wink::+1:


Yes, that’s happen to me, too!
I just have tested it playing a 50fps File with 50hz Output set as Standard…

James, could you please consider to correct this behavior or in the best case give us a Setting to adjust this „Waiting“-Screen? :wink::+1:

1 Like

I’m fairly certain Infuse isn’t paying attention to whether the fps of your content is different to the current fps of your TV, otherwise we wouldn’t be having the problem I described in my previous post (see above).

1 Like

Christian is it possible to change the title of your post, now that we know this problem isn’t just limited to QMS?

Do you really think this is his highest priority right now? There’s only one person on this entire forum who even has a QMS TV. And it’s not like content doesn’t play, it just takes a couple seconds. There’s waaay more important things to work on, don’tcha think?

I’m sure it will get considered down the road. Right now the proposed setting option will probably just confuse enough people that this forum gets a million questions about what it does. :slight_smile:

@FLskydiver But it’s not just QMS affected by this, it’s also slowing down people using the standard Frame Rate Matching. And there’s always something more important to fix, but this is an issue! :grin:

1 Like

? This doesn’t even make sense. They’re the same thing. Are you saying that Infuse inserts a few seconds of blackness before playing everything? Are you sure you’re not just seeing a slight delay caused by Infuse needing to begin a stream and begin building a buffer?

@FLskydiver No it’s not buffering, as if you turn off Frame Rate Matching, it plays instantly.

Yes, infuse inserts a blackscreen before playing anything, when Frame Rate Matching is enabled. Even when it doesn’t need to. This is the issue.

1 Like