Purchased Infuse 6 Pro "bundle" upgrade. OK on iPad and aTV, can't download on iPhone

Today I purchased the Infuse 6 Pro “bundle” upgrade, as I own Pro 5 already. The new app downloaded just fine on my iPad and my aTV, but on my iPhone when I go to it in the App Store, the bundle just says “Purchased”, with NO WAY to download Infuse 6 Pro.


Also, I note that Infuse 6 doesn’t import the library settings (eg. NAS servers, Plex) from Infuse 5 Pro, with iCloud storage enabled on both! Is this a bug or a deliberate feature?


Sometimes restarting your device can help force things to update.

Also, there’s a good chance that tapping the ‘purchase’ option for Infuse Pro 6 will simply present you with a dialogue saying you already purchased the app, and it will be downloaded for free. It’s not possible to purchase the same app twice under the same Apple ID.

Same problem here. Purchased Infuse Pro 6 Upgrade Bundle on iPhone (Download ok), ATV 4K (Download ok), iPad Pro says that I need to pay 27,99 EUR. Rebooting the iPad didn’t solve the problem.

Same problem for me. Bought upgrade bundle on iPhone. On iPad Bundle is shown as bought but infuse 6 is still 27€. Reboot without success and if I try to purchase it show the full amount of money. help?

The problem gets worse. I deleted the infuse pro 6 app on the iPhone. Now the iPhone is also not able to redownload the app. The Bundle still shows bought but only v5 is able to load. V6 now also shows 27€… So I paid for nothing…

This is affecting a few other users too. Here’s the solution, for now.

If the bundle says ‘Purchased’ but you’re seeing a price next to Infuse Pro 6, you can simply tap the price button like you are going to purchase the app. Doing this will force the App Store to recognize your purchase, and will display a prompt saying you’ve already bought the app and can download it for free.

It’s not possible to purchase an app twice on the same Apple ID, so there’s not really a risk of buying it again.

Ah James, but here’s the issue: On the iPhone there is NO button to “re-purchase” the bundle! There is just a greyed-out button saying “purchased”. If I click on the bundle description it shows me the two apps (v5 and v6 pro). The v5 app says “Open” because I have it already. The v6 app gives the FULL purchase price (not the slightly discounted one). When I click it it does indeed want to charge me $38.99 again!

It would seem to be an issue with having a 2-app “bundle” in the app store, I’m guessing.

I have reported this to Apple as well. I note that quite a few people are having this issue, according to your forum.

Add me to the list. Just bought Infuse Pro 6 upgrade from 5 Pro (both standalone). Installed fine on my iPad Air, shows up fine as a purchase on my Apple TV 4K and can be installed for free, but this is what I see on my iPhone X (see attached file).

Also, is it possible for you guys to put up a brief guide on how to transfer our data from Pro 5 to Pro 6? Again, both on my ATV and iPad, there are no prompts or any other indication of any method of transferring the library. Do we have to set up the network shares again, then let iCloud sync between the two versions?

We’ve had a few reports of this today, and it seems to be some sort of issue with the App Store.

Here’s the steps to resolve, which has been confirmed to work by a handful of people so far.

  1. Open the bundle details, and confirm the bundle appears as purchased.
  2. Tap the price button that appears next to Infuse Pro 6, like you are going to purchase it.
  3. The App Store will ask for Face/Touch ID to confirm your purchase (scary, but continue).
  4. You’ll get a popup saying you’ve already bought the app, and it will now be downloaded for free.

We’re not sure why this is happening, but it only seems to be affecting a subset of people. Rest assured, if you already own the bundle there’s no way to actually ‘purchase’ the Infuse Pro 6 app again…the App Store simply won’t allow it.


Proceeding with the Infuse 6 Pro version after the bundle purchase worked for me. It was a bit scary as it prompts you to confirm your purchase before the following message:

“This update is free because you own a previous version of this item. To get the update now, select OK.”

Thanks - as noted above, it even provides a prompt saying that the update is free once you click the price button (see attached). Unfortunate that this is happening to Infuse 6 on the app store, I’ve never seen it happen before.

Great! Glad to hear it’s working. :slight_smile:

OK, just re-checked the app store on my iPhone. Opening the bundle description now correctly shows the “download-cloud” icon that indicates that it is purchased, and it can now be downloaded. Thanks James for help.

WA Worked for me on my iPad aswell :slight_smile:

Worked - but not really good. On a second device i can buy it again and also get the pop up that’s this purchase is free. This stays like that. Deleting the app you have to buy it again, Also infuse 6 is not shown in the purchased item list…

Yes, it’s unfortunate and we’re not sure why this is happening in some cases.

We’re hopeful it’s a temporary issue, and things will start working normally soon. Perhaps after we release the first update (6.0.1) that will force things to refresh and get back to normal.

I just tried this, and it actually charged me a second time. First purchase was Pro 5, which upgraded to 6 on Apple TV. Second purchase, today was on my ipad, for Pro 6. You mentioned that it would recognize a Pro user account was already purchased on this apple ID, and not charge again. What do I do now?

Contact Apple because their store is effed. They should be able to issue you a refund for the double purchase.

Can you try a factory reset of your device that you purchased the upgrade bundle on. Go to Settings, Erase all Contents and Settings and setup as new. I had to factory reset my iPad due to $24.99 still showing up on Infuse Pro 6 after purchasing the upgrade bundle in order to reset the App Store cache. After the factory reset there is a cloud icon for Infuse Pro 6 instead of $24.99.

I tried everything - including a complete reset. What worked for me was to download a free app from the organizers account - any free app will do - and it jump-started everything and Infuse became available to download on the other family accounts. YMMV