Problems with Smart Installer

I just purchased aTV Flash, but I can’t seem to get the Smart Installer to work. It continually crashes (Install Partial or Failed). Not sure what I’m doing wrong here. I have the most up-to-date versions of both aTV Flash and the Apple TV OS.

Thanks in advance!

Which version are you installing? v.3.5.2? If this is the version, I have the same problem.

The Smart Installer patch files ahould still be installed after the new aTVFlash software. You only lose those extensions after running an Apple TV restore or update.

I’ve the latest aTV update and the Apple TV also at latest update (as of 5/8/09).
I’m just not able to get Smart Installer to install to completion. Similar to this post
[ http://forum.atvflash.com/viewtopic.php?f=5&t=867 ]

I keep getting one of the option result: mach_kernel.prelink already patched or unrecognized

I’ve even tried changing the .dmg file from the 10.4.9 to 10.4.10 but to no avail.

Because of this, I’m unable to have my external USB drive show up in ‘Places’ [yes, I’ve also viewed the procedure on
ScreenCastOnline]

Please advise. Thank you!

PS. My goal is to access the USB external drive as a ‘Local File/Folder/Drive’ in ‘Places’, and NOT to have it replace
the internal drive as the ultimate destination for iTunes.

I bought today aTV Flash I have the same problem to install the Smart Insaller.
Also the same error msg.
I need this to connect USB hard drive and for streaming from Netgear NAS
I would need also really help.
THX FMAD

Hi guys,

I habe solved on my Apple TV the problem with the Smart Installer.
What I have done is:

  • Restore Apple TV on factory settings (this delete everything in the Apple TV)
  • After starting if necessary configure your network
  • Update your Apple TV to the latest version
  • After starting if necessary configure your network
  • Install aTV Flash
  • After it have installed ATV Flash and have restart your Apple TV
  • Do not configure and install anything on the Apple TV and aTV Flash just only install fist Smart Installer.
  • After Smart Install have been installed successfully, you can configure your Apple TV and install other programs.

I can now stream my videos from my Netgear NAS Server with UPnP AV
At least in my situation is workaround had helped. :slight_smile:

Cheers FMAD

PS: Now I have to solve another new problem Flash-player does let install at all. :frowning:

After a Factory Restore, Smart Installer was able to successfully complete installation.

However, my external USB drive (formatted in Mac OS Extended journaled) does not appear in the ‘Places’ folder in ‘Files’ regardless if I’d connected it directly to the AppleTV or linked via a Hub. Even tried different combinations of reboots.

I’ve also tried unplugging & plugging it back in.

How can I make the USB drive appear? Please help!