Problems with External Hard Drive being recognised

I have 2 ATVs, my original 40GB I have had minimal issues have done updates etc and after tinkering I have managed to get it to recognise my seagate 250GB external hard drive and even allows me to play movies (mainly avi files - so nothing extra ordinary). My new ATV (from Ebay) all works great with standard ATV out of the box stuff, and when added the ATV Flash most things work fine (I notice difference in the start up picture) However I can not get any programs (I use NITO mainly) to recognize the hard drives or play files - I thought maybe its the external hard drive so I tried USB sticks, and a Le Cie 1TB and still nothing. I have dont up dates, I have even factory reset it (although I don’t think it completely wiped it as there were old things on it still???) I am at a loss and would appreciate any assistance. I have read though many of the forum topics and noting seems to be the same problem - I haven’t even tried half the stuff that apparently it can now do.