Problems with all video player apps

Ok, so I have gone through this with the best luck up until now. I’ve really had no issues, or at least that I couldn’t find an answer to. But now…

All of my TV shows went away, and some of my movies. I could find them in the ATV files, but not in Sapphire. I had tried many things, no new stuff would be saved, and I started having more and more old stuff disappearing… So this morning I decided just to redo everything. I did a factory reset - then updated ATV, then put a fresh ATV Flash on it, ran Nito Installer, updated Sapphire and installed ATV files, and then ran the Import All on Sapphire, and selected all 700 something files, added artwork, and nothing… It didn’t save.

Then I saw the post abut the MetaData V3 file, downloaded that, FTP’d it in, and ran everything again - all my TV shows were back! But only 2 movies… I’ve tried everything, but nothing is showing in Sapphire for movies other than the same 2 movies.

I figured, at least for now, I’ll just watch them in either the ATV Files, or Nito TV. Well, when I select Nito TV, it gives me the high pitched “bounce” sound, the “fail” sound (like when you press “up” when you are at the top of a menu). So I went to ATV Files, Movies - It’s blank. Apparently Sapphire can see them all, when I run it it says it’s backgrounding 702 files, loading URL’s all that jazz - but it won’t put them in. I’ve checked the exteranal, it works great on my Mac, and all the TV show vid files are playing - iTunes sync’ed media plays fine - it just won’t let me into Nito, ATV Files (tried uninstalling and reinstalling both - no change) nor will it allow me to see any other movies files other than the 2 that show in Sapphire.

I tried deleting the MetaData file, and re-running it, uploaded a blank file - still shows the 2 movies and nothing else, as well as all the TV shows. I’m kinda stuck and not sure what to do from here…

Have you installed the 8.0.5 update for Sapphire that is available through the Maintenance --> Manage Plugins menu?