Problems jailbreaking with iTunes 11

I just installed iTunes 11 today (on Win7) and I finally decided to try jailbreaking my ATV2 tonight. Well this was probably bad timing since I keep running into an issue during the process and I’m wondering if it’s because of iTunes 11. I get to the point where iTunes opens up, but it doesn’t auto restore, so I hold down shift, then click the button to restore in iTunes to do it manually, then point it to the .ipsw file with the SP in the file name in My Docs\Seas0nPass. So then it starts to go through the restore process in iTunes, however it errors out after a few minutes with “The Apple TV could not be restored. An unknown error occurred (1604).”

 

Any ideas? Thanks in advance!

Never mind. I restored again with the original apple firmware, then ran through the process again and it worked. I still had to manually choose the file to restore though. Weird…

The new iTunes breaks the restore script slightly it seems.  Nothing fundamentally wrong with jailbreaking that I can see caused by iTunes 11

still work on windows 8 using itunes 11 on 12-01 @ 5:25pm est

Yes - actually this doesn’t work on iTunes 11 contrary to my earlier post.  It seemed like it was working but then wouldn’t (odd “device not recognized” error in iTunes 11). Luckily I still had a Macbook with iTunes 10 running and was able to restore to ATV 5.1 but, of course, this isn’t jailbroken yet so no ATV Flash until the jailbreak comes through.

mine hangs on … Please wait while script is running… this is anoying , some one please help . Windows 7 and itunes 11.0 ATV2… what else could be wrong?

 

You have to manually restore it when Itunes 11 pops up, Hold down shift key and click on restore

 

I tried to restore my APTV2 after getting the 1604 error but my device is now not found by Itune?!? Any idea??

 

Thanks a lot

Please see here for a workaround. http://forum.firecore.com/topic/9283