Problems Jailbreaking Apple TV 2 5.1.1

Hi all,

New to this community. I have some experience with jailbreaking before, but can’t seem to get it to work on Apple TV 2 running 5.1.1 (5433). I’ve used Seas0nPass 0.8.8 with iTunes 11, but no luck. After the DFU step, Seas0nPass gets stuck at “Please wait while script is loading” and I don’t see any progress bar in iTunes that indicates that the IPSW is being restored.

Is 5.1.1 a tethered jailbreak? Meaning I have to connect the wire?

I’ve read a few threads here (see http://forum.firecore.com/topic/9304?page=1), but I’m just lost.

Do I need to restore to 5.0.2 and then run Seas0nPass again?

Thanks for your help.

EDIT: I tried restoring the Apple TV to 5.0.2 from the firmware generated by Seas0nPass but I keep getting an error from iTunes saying that it can’t be restored.

EDIT 2: I was able to restore to 5.0.2 firmware generated by Seas0nPass, but now I can’t jailbreak it. iTunes does not restore. I manually tried to select the SP firmware file from ~/Library/Application Support/Seas0nPass/… but that’s not working either. I get an error from iTunes.

EDIT 3: It finally worked. Not sure how. Please close the thread. Sorry for the trouble!

Im facing the same problem tha you described but until now I couldn´t solve ! 

Can you help me ? Tks.

Hi sonicx,

 

If you just post how you got it to work, that would of great benefit to everyone else. Thanks!

 

-timeimp

Hi all,

Here’s what worked for me. My Apple TV 2 was running 5.1.1 initially, which is the latest version.

  1. I first restored (aka downgraded) it to 5.0.2 from the firmare generated by Seas0nPass. It’s in the Tether folder in your documents.

  2. I then ran Seas0nPass again on the 5.0.2 firmware, but it was getting stuck at the last step where it is supposed to automatically installed the JB firmware via iTunes. The file location may vary whether you’re on a Mac or PC.

  3. I manually selected the JB firmware file generated by Seas0nPass and restored it in iTunes by holding the alt-key and clicking on Restore. Then navigate to the JB firmware and iTunes will do the rest of the work. If you keep getting an iTunes error in the end like I was, just restarted your computer and try again. That did it for me.

Hope it helps! Lots of manual work.

Hi,

same problem here.

i have restored to 5.0.2 like sonicx.

now, where can i find the jailbreak firmware? i can’t find it in : ~/Library/Application Support/Seas0nPass/…

thx !

 

edit: I found the problem: itunes always started in fullscreen mode!

Please wait till new Seas0nPass release…