Problem with Surround sound

Few weeks ago I’ve upgraded to the latest version of aFlash TV. Now I found out that I can’t play surround sound. For example, if you take one of this videos:

http://www.dolby.com/us/en/consumer/technology/home-theater/dolby-digital-plus-download.html

it can’t play the surround sound. Before, everything was great. I was able to play all my HD mkv movies with 5.1 with no problem. Now it’s just stereo or no sound :-/

I didn’t change anything. I still have the Apple TV connected to my receiver via optical cable. I’ve just updated the software.

 

Any idea/help?

 

Thanks:)

 

P.S.: if anybody already asked this question, just post the link. I found just some old topics about alder versions…

Is Dolby Digitial enabled in the Media Player settings?

Yes. I’ve also tried to turn it off and on again. Didn’t help…

 

EDIT: I mean it’s enabled in Settings -> Audio & Video -> Dolby Digital -> Auto (Tried also on)

Is there some other Media player setting?

Yes, please ensure the AC3 option is enabled in the Media → Settings → Playback menu.

Of corse this menu. I don’t know why I missed it.

Thanks a lot! It works now:)

Hi, i got similar problem. Everything and every *.mkv files (720p) worked perfectly on my ATV2 with aTV Flash v1.3 before (i used 2.1 Channel).

But after Update to aTV Flash v1.4 or v1.5, if i playback a MKV movie, i got always Sonic Boom (i’m not sure whether this name is correct). I tried every possibility but failed.

So i DOWNGRADED aTV Flash to v1.3 again, now it works stably like before!

 

PS: I didn’t upgrade iOS of my ATV2 to v5.0, it’s still v4.4.4

 

I do not know if it will help, but have you tried playing with the “Centre Channel Boost” setting under Media Player->Settings->Playback.  That is relatively new and might explain the difference in behavior?

thanks for the reply, itimpi.

i have tried to turn off central channel boost (disabled, NOT +6dB, NOT +12dB) on aTV Flash (Black) v1.4 and v1.5, but it did’t help.

 

Regards

Lee

Can you describe the ‘sonic boom’ you are hearing?

If it sounds like static, you may try disabling the AC3 and DTS options as described above.

for example: somebody’s shooting in the movie or strong dynamic sound such as Flying by of the aircraft will lead to “sonic boom”.

I disable the AC3 and DTS always becoz i got only 2.1 Channel Speaker

 

Probably best to open a support ticket for this one.

PS - This is what I think of when I hear the phase ‘sonic boom’. :)

thanks for your advice,  James :slight_smile:

 

Regards

lee