Problem with SMB & NAS

I have a problem with SMB at my ATV4. It used to work fine and NFS/SMB was at Favorites. When I trying to connect via SMB I have connection problem.

  • I don’t change any preferences at my NAS
  • Firewall disabled
  • Tried to restart ATV, reinstall Infuse [NOK]
  • Tried disable iCloud Sync [NOK]
    -Tried to connect from MBP via SMB with same credential [OK]
  • Tried to connect via SMB from iPhone (Infuse) [OK]
  • Tried to connect via SMB from iPad (Infuse) [OK]

So even after I added SMB favorites from iPhone/iPad it will appears at ATV but still have a problem with connection.

  • router - rebooted
  • NAS - rebooted
  • ATV - restarted

tvOS - 14.0.2
Infuse 6 - last version

If you are still seeing this, please send in a report from the ATV (Infuse > Settings > Submit Diagnostics) and post the 5 digit code here.

Already sent to support yesterday, code 21RTF, support request #130128 with more details.

Awaiting for your reply.

UPD Problem gone when I’ve switched to Wifi. Any ideas?

Bad cable somewhere?

bad cable or bad port. Try connecting via IP instead of using hostname.

Okay, I’ll bite. What is UPD?

Changed another cable and another port. Same problem. Router Asus AX88 (Merlin)

Over Wifi - no problem, switched cable and port - same.

I was asking the meaning of “UPD”


I see. Just a suggestion you can confuse other forum members (yes, I’m frequently in that catagory :smile:) with acronyms and miss out on good feedback concerning your problem.

If you’ve changed ports on your router and the cable and still see the issue it may be an internal router setting or possibly an Apple TV Ethernet port going away.

Same problem with cable with VLC also(SMB/FTP), other services over internet works fine. So for me is a brainstorm to get the reason. I guess problem can be at router settings…

Is it possible you have the Apple TV set up for network guest with internet access but not for LAN file sharing on the Ethernet MAC address but full privileges for the WiFi MAC address??

Nope. Guest network disabled.

Are you running multiple vlans or do you have port trunking/spanning enabled on either your NAS or your router? If so the problem might be there.

Guest Wifi may be disabled but the Ethernet MAC can still be restricted from the LAN and not the Internet.

Finally done. At router settings Link aggregation and Spanning tree protocol(no idea what is it) was on, I’ve disabled it so right now no problem with cable.

Thank you guys for advice.

Link aggregation was probably combining your ports into one (good for doubling bandwidth with multiple network cards or for failover). Spanning tree you could probably leave on but won’t need unless you add another switch. Spanning tree prevents network loops in home environments.

So looks like this options could be ON. But why disable solved the problem?