Problem with Metadata for Doctor Who - Help!

I am having a problem with some metadata that is being returned incorrectly but only for one episode in the series all other episodes are returned correctly and the episode looks fine on TMDB.

The file name is: ‘Doctor Who (2005) - S00E156 - The Husbands Of River Song.mp4’ and it is located in the following folder structure: ‘TV Shows/Doctor Who (2005)/Specials’

In Infuse the episode is displayed as ‘Doctor Who (2005) - Episode 156 - Doctor Who (2005)’ and is should be displayed as ‘Doctor Who (2005) - Episode 156 - The Husbands Of River Song’

Can anybody explain why this particular episode is going wrong as I just can’t work it out and its driving me nuts!

Hmm, ‘The Husbands of River Song’ special appears to be listed as episode 148.

I’ve just tried using episode 148, and it seems to work on here (see attached).

Thank you so much James that has solved it :slight_smile: I thought you were pulling the metadata from

Great! :smiley:

I use Infuse for iPad and Apple TV and I’ve been having the same issue with almost every tv show for the last month or so.

I use Filebot to change/update the file names and - prior to now - Infuse would apply the metadata to get the synopsis etc for each episode. I’ve tried using the MetaZ app to see if it’s a metadata issue but this hasn’t worked.

This issue is not linked to just one TV show. It’s happening to all of them.

Hi everyone!

I’ve also been having issues with only some of my TV shows not displaying in Alphabetical order with the rest of the list of shows. The best example is, as indicated by this post, Doctor Who and the ‘Specials’ folder as well as ‘COSMOS’. All other TV shows, once they have gone through their initial metadata retrieval and Season sorting, will “fall” to the bottom of the list. Doctor Who, Cosmos, and a few others like The Late Show with Stephen Colbert, however, stay firmly above the other shows in the list. I use Sonarr (aka NZBDrone) to manage my renaming. Here is a directory listing in Gist form.

I would love to help get this sorted out, please let me know how I can help!

What’s probably happening is Infuse is grouping series with multiple seasons above those with single seasons.

This will no longer be an issue once we implement Library View in 4.2, though a workaround for now would be to add a ‘Season 2’ folder to the series that currently only have a single season.

Not sure if you looked at the Gist, but almost every show I have is multi-season, including Doctor Who, with the easiest examples being Gotham, New Girl, Castle and Rick and Morty. These all have multiple seasons and appear “below” Doctor Who. Additionally, thinking it had to do with ‘specials’, Archer is also displaying “Below” Doctor Who and does also have a Specials folder.

I did look at it, and that’s just one thing that stood out initially - though based on your feedback it seems it’s affecting both single and multiple seasons.

I honestly am not sure why this is happening, though we’ll take a look at it. As I mentioned, this will not be an issue once 4.2 is released as we’re moving to a library based system instead of folder based (browsing by folders will still be an option of course).

The Doctor Who listings that you shared are missing one of the xmas specials.
In 2011, The Doctor, the Widow and the Wardrobe was broadcast on Christmas day (The Doctor, the Widow and the Wardrobe - Wikipedia) but it’s not on that list so I don’t have the epidode # to use with S00.

Found it. My bad. Please delete :slight_smile:

Hi James,
Thanks again for all your hard work including the 4.3 update.
I gave list view a try but my children find the poster view easier to navigate.
Can I make a request to chose the Metadata source when searching TV episodes?
I have an extensive collection of programmes for the children but the source seems limited by defaulting to ->movies.
If a title is found there, Infuse stops looking, ignoring the /TV show results on themoviedb database and ingnoring
For example, Peppa Pig S01 E12 Snow is available under the TV listings on themoviedb site.
But if a search for Peppa Pig is done and the results limited to movies only, then that list is identical to what Infuse returns on the TV when trying to manually search for metadata.
Can you please have a look at tweaking the search function in the next release?

Infuse uses 2 different databases, but before it searches either it will try to determine if a video is a movie or a TV show. It does this by looking at the file name. If it falls into one of the supported naming styles for TV shows, TheTVDb will be searched. TMDb will be used for everything else.

A list of the supported naming styles can be found here.

Hi James,
Thanks for the quick response.
Yes I am already using the required naming convention as i have a UPnP server running on my Mac.
To be absolutely sure I renamed all of the series 1 files to make sure the correct convention was being adhered to.
For example I had my sample episode named as → Peppa Pig S1 E12 - Snow.avi, it is now → Peppa Pig S01 E12 Snow.avi
It makes no difference to how the file is named by the DLNA server, and a manual edit inside Infuse shows “⊘↵ Nothing Found↵ No Matches Found For This File"
As I say, manually entering a search for “Peppa Pig” only returns results from the Movies catalogue. The TV shows list is missing.
Just saying, I think I can see why the shows don’t automagically load the metadata.

Although that name looks valid according to the FireCore suggested naming format, may I suggest that you also try removing the space between the series and episode number and see if that makes any difference, i.e. Peppa Pig S01E01 - Snow.avi

@remotevisitor thanks for offering advice.
I think the convention I am using is compliant, but I renamed the whole Season One set of files as you suggest with the space removed just for the exercise.

From Metadata 101 on this site-

These are the allowed formats:
TV shows
Note: Period, space, underscore and dash can all be used interchangeably as separator characters.

ie spaces, no spaces, hyphens, underscores - it doesn’t care.

After I did this I hit the refresh button in the UPnP server (TVMOBiLi - long time user, love it) then went to the TV and navigated to the season one folder.
Infuse confirmed the files needed reloading Metadata as all the poster art was blank, the clock face ran for a few seconds while it looked for Metadata but then loaded all the icons from what it could find in the embedded previews as nothing found (as before)
When navigating into a particular episode and pressing the “Edit” button while the recatalogue is pending, you can see Infuse looking up a listing but then after a few seconds shows “Nothing Found”
I know the naming convention is compatable because TVMOBiLi will not recognise files as TV shows and place them under the Movies listings if the naming is non-compliant.

I am starting to wonder if it is a DLNA thing that is central to my issue.
Is everyone else using an UPnP server and getting TV shows loading the Metdata correctly?
I need to create a shared folder the TV can see and try hosting some files there to see if it starts working but for some reason I can’t share any folders on my Mac that the TV can see. I might just load some files on a USB stick and share them from my router to see if they can be hosted from there, just to see if it works.

So yeah, when I put the files on a USB stick and attach to the router, it shares them over UPnP and Infuse can work from that share.
And, you guessed it, all the shows load the correct Metadata. And order them into folders of season number. Magic!!

What I have determined is that basically no TV show streamed from my Mac over UPnP loads any Metadata correctly. Its’s just random Movie poster art if it ever finds anything.

Unfortunately I’m not prepared to stop using the daemon as it pefectly manages the multiple drives and folders I have and streams them out to either Movie or TV show based on the naming of the file.
I also have some Samsung BD players for watching media on that rely on my current DLNA arrangement.

James, can you please give me some advice on how to move forward on this?
Do I need to go back to the TVMOBiLi vendor to see if there is something they are doing differently under their implementation of the standards?

One thing I notice is that the TV is not being seen by TVMOBiLi as any device from the Mac. Usually if a BD player or iOS device is streaming, it is shown as a device conneced and the daemon changes certain details in the way the media is delivered depending on that info. It seems strange the TV running Infuse has not such reporting.

Really appreciate your help.

What file name is Infuse showing when you open the ‘Edit’ option on Apple TV?

Hi James, Thanks for jumping back in.

It does not show the full file name, for the above example file:

“Peppa Pig S01 E12 Snow.avi”

When I select the episode from Infuse using ‘Edit’ the name shown is:

“Episode 12 - SNOW.avi”

…and below that the nothing found dialogue.

(the DNLA server has a habit of capitalising everything)

Doing the same when the file is shared from the router shows the actual full file name and below a list of alternatives.

So, it looks like your DLNA server is modifying the filenames it presents to apps like Infuse. This is what’s preventing Infuse from being able to pull the correct info.

You may want to look through the DLNA settings and see if there’s a way to disable this option.

Cool thanks for that.

It serves the episode as:

TV Shows: “NAME OF FILE BEFORE FIRST DELIMITER ALL CAPS” → ”Season““space“(value after first delimiter)“Episode““space““value after second delimiter““space““hyphen““space““ANYTHING ELSE IN THE FILE NAME ALL CAPS” sorry for shouting :slight_smile:

Odd because it doesn‘t do that for Movies.

I’ll email Nathan the developer and see if there’s a way to attach the actual file name to the feed.

I can‘t think of a way of turning that on as I’ve been using it for over ten years and fairly familiar with the interface.

There are command line controls though that I”m not completely across.

As I say it may have to do with the server not knowing what device is streaming the file.

cheers dude!