Problem with forced subtitles

Hi,

In films with french subtitles and forced french subtitles, infuse should select the forced subtitle as the audio is set to french. But it always select the full subtitles instead.

BR

Didier

It selects based on the force flag. Is it set right?

How can I check that ?

We are working to improve support for some flag types, but Infuse will currently support the forced flag. To best utilize this, you can disable the ‘Show Subtitles’ option found in Infuse > Settings and Infuse will show forced subtitle tracks, if any are present.

To see which flags are set in your particular videos, you can run one of the videos through MediaInfo.

MediaInfo is a free download available at the links below.

Mac
http://fireco.re/YCm3

PC
http://fireco.re/YCY2

I can not confirm that forced subtitles are shown when I disable them in Infuse.

Currently Infuse handles subtitles extremely awful.

If subtitles are enabled, subtitles are automatically shown, for the full movie (which is stupid, why is this the default setting?)
If I disable subtitles no subtitles are shown, including the forced subtitles.

The only way to enable the forced subtitle is to select them manually while watching the movie.

What brings me to the next point. It seems that Infuse remembers the subtitle selection for each movie instead of resetting them to the default value after restarting the movie (WTF?).

I add the subtitles and forced subtitle via „subler“.

My subtitle settings works without any problems on QuickTime on MacOs and a very long time on Plex, before Plex broke the forced subtitle support totally.

The general thinking here is that if you have subtitles, you probably want to see them. Of course this isn’t always the case, so you can disable the global setting to avoid having Infuse display these.

However, in addition to the global setting, Infuse allows you to manually set subtitle settings on a file-by-file basis. For example, you may want to have subtitles off, but display them for a foreign film. In this case, Infuse would remember that setting the next time that video is played.

With regard to forced subtitles, Infuse will display these when Show Subtitles is disabled, but this relies on the subtitle track having the ‘forced’ flag set. This is a flag that can be set in Subler, as shown in the attached screenshot.

This may be for english customers true, but if you are non english you often have subtitles in your movies and you just want to enable them when necessary.

Maybe you should add an setting to change this behavior. Normally I want to enable subtitles temporary. If I leave watch the movie a few month later again, I expect it is back to the default, if I forget to change the settings back manually.

I changed the setting of the forced subtitle like on the screenshot, but the forced subtitles are still not shown (See screenshots).
The only change I did was adding “Contains forced subtitles”, but I would expect that forced subtitles should be shown without the “Contains forced subtitles” flag. At least iTunes and Quicktime don’t need the flag for forced subtitles.

Thanks for the suggestions. We have a few items in this area we are looking to improve, and will take your feedback into account.

Also, apologies - a screenshot with the correct settings for Subler is attached.

Hey james, thank your for your response.

I changed the settings like you suggested in your screen shot:

  • Referenced “Forced Track” in the subtitle to itself
  • Checked “Contains only forced subtitles”

But the forced subtitles are still not working. I am using Infuse via Plex.

However, it should work without those settings, but with the settings from my screenshot the forced subtitles are working perfectly with iTunes and QuickTime.

I am seeing this same problem. I have Black Panther in an unprotected .m4v with two subtitle files. One is the entire film and the other is only the parts where they are speaking in the foreign language. The foreign language subtitle track is marked as forced in Subler as outline in the above posts. I also ran it through Media Info and it shows it as being tagged as forced. I added a screenshot below. It shows up automatically in iTunes and in the computers app on an AppleTV 4, but the same AppleTV 4 will not show the forced subtitles using Infuse reading from an external hd or from a Plex server unless I go in and manually set them to be visible.

screen_shot_2018-06-01_at_11.38.33_am.png

What is the ‘Show Subtitles’ option in Infuse > Settings currently set to? Does changing it make any difference for you? Even with this disabled, Infuse should be enabling subtitles that are tagged as forced.

I will also mention the upcoming 5.7.3 update will honor the Default tag for both audio and subtitle tracks, which could potentially help in this case.

After I tested all your subtitles hints without any success I don’t think that coachdport will have any success with changing the settings :wink:

I think this is an issue which only appears in combination with Plex. Did you tested forced subtitles with a Plex-Server? (“Subtitle Modus: manual” on the Plex Server admin menu: Settings->Server->Language and also check “Automatically Select Audio and Subtitle Tracks”).

Offtopic: Will 5.7.3 will also fix that multiple audio tracks in different versions (e.g. 2.0 stereo and 5.1 surround) are shown separately instead as one language option? The native AppleTV shows only “English” and selects automatically 2.0 or 5.1.

I changed the subtitle settings to ‘On’ and tested it. I changed it to ‘Off’ and tested it. I tested it through Plex with the subtitle options set as above. I signed out of Plex and set up Infuse independent of Plex and tried the subtitles with it set to ‘Off’ and ‘On’. I’ve tried it through the Plex app on the Apple TV. I’ve tried it through the MrMC app on the Apple TV. The only thing that works is through Home Sharing and the Computers app on the Apple TV. Maybe Apple it right. ‘It just works’.

Yes, I can confirm that forced subtitles are working with Home Sharing on the Apple TV or on macOS with Quicktime.

I found a work around until hopfully this gets a more permanent solution. Using Subler, if you make sure the forced subtitles are in their own text file and that text file is the first text file (including and other subtitle files or chapter marker files) and set Infuse to show subtitles in the settings, the subtitles will show up when needed. Takes some work to get there, but it works for the time being. Maybe one day, subtitled can get figured out properly. Infuse isn’t the only program having this problem.

I have english subtitles for pretty much all tv shows and movies, as the wife likes having them up as ‘backup’ in case of mumbling or well, Tom Hardy. :wink:
(Taboo recommended).

I always prefer to have the subtitles in an external srt file - even if they are packaged within an mkv file for example… and especially with those enormous bitmap type subtitles so they can be turned off/ignored.

For a Mac, here’s some particularly great apps:- (proably Win alternatives… available)

  1. Jubler - can adjust subtitles that are a bit off sync… easy to use and converts formats to the standard srt…
  2. iMkvextract - iMkvExtract for Mac: Free Download + Review [Latest Version] , can extract the various bits out of an mkv file, so extract srt subtitles or the hated bitmap variety which can then…
  3. Subtitle Converter, from Andy Apps in the App store, will convert that ugly bitmap into srt for you.
  4. mkvToolnix - is an all round heavy duty mkv tool for demux, muxing and more

Other than that, Infuse handles subtitles pretty well, and has built in time shifting now also.

I’ve suffered with Plex in years gone by… happy to have ditched it,

The forced subtitles worked quite well with Plex a year ago. But somehow the geniuses managed to break it. :wink:

No improvements with 5.7.3

Forced subtitles are still ignored ?

Are you streaming from Plex or a non-Plex share?

I am using 5.7.3 and forced subs still aren’t working. Within the last 20 minutes I have streamed from a Plex share and a non Plex share with subtitles turned off and on and back off again. The only way to see the forced subtitles is to turn on the subs and select the track manually.