Problem(s) JB'ing - "not elegable" etc

Hi there

I have a new-out-of-the-box ATV2, and I’ve done this so far:

  1. used it a bit. It’s lovely!

  2. Got the firmware (AppleTV2,1_4.3_8F305_Restore.ipsw ) from the LOVELY person who linked to it in their dropbox account.

  3. restored that firmware via a normal itunes restore (which worked fine - yay, I have 4.3 now!) (apple’s servers are still stuffed for me)

  4. Used Seas0npass to make a new IPSW (which worked). Flipped the ATV2 into DFW mode (again, worked fine), and then ituens poped up and it automated it to restore the created IPSW 

this is where it all goes wrong. I either get a “not elegible” error, or error 21, neither of which I can find any info on how to fix.

I appear to have a single entry in my hosts file from seasonpass:

74.208.10.249 gs.apple.com

if I remove this, it doesn't work, unsurprisingly (can't contact the server I think?)
Any ideas? am I doing something wrong?
thanks!

What i have found is that after the itunes restore

remove the usb cable and close down itunes

it seems if itunes is still open that something in the jailbreak process gets screwed

however am not sure what you mean about apples servers being “stuffed up” and why you had to get a 4.3 from someone other that the apple server?

I restored two atv2 yesterday and they are working a treat

 

I can’t get iTunes to restore the JB’ed ipsw at all - only the original, unmodified one.

I suspect it might be my mac, so I’m going to try it on another machine tonight. However, Apple were sending truncated .ipsw’s recently (see here: http://forum.firecore.com/topic/4822 ), and I can’t download it from them, regardless of how I do it (using seasonpass or itunes, or even the appletv itself!)

So, it works for some people - thats enough to make me try other machines here first :slight_smile:

Hi!

I didn’t try JBing the ATVs on a mac, but I think this shouldn’t be a problem.

I got the “not elegible” error only when using other JBing solutions or an older Seas0nPass version, are you using the newest release?

And the 21 error says that your ATV isn’t in DFU mode (the 7 secs PLAY/MENU button pressing thingy). I wrote a small post for people who also had problems with DFU mode. --> http://forum.firecore.com/topic/4822#comment-18407

Hope this helps…

 

Cheers

oxy

Thanks - I’m using the latest seas0npass with the latest IPSW (so I can find), from what I can tell. Check for updates says it’s the latest, and I downloaded it on friday, so…

I didn’t know error 21 (from iTunes) is not-in-DFU mode. I put it into DFU mode for the JB, but it still fails - do I need to put it back into DFU mode for when iTunes restores the IPSW? So basically doing it twice?

I’ll give it another go tonight.

No, you don’t need to do it twice. During the JBing itself you don’t even need the ATV connected or iTunes started. 

Here’s how I’ve done it:

  1. Disconnect ATV from everything
  2. Fire up Seas0nPass and let it build your custom firmware
  3. When it's done, it will tell you to connect your ATV (only USB) and to get it into DFU mode
  4. It will do some more JBing stuff (IDK what exactly, just let it rumble^^)
  5. Now it tells you to start iTunes (just let Seas0nPass running) and to restore it with the new built firmware

That should do the trick…

 

Awaiting your feedback^^

cheers

Yup, thats exacty what I was doing… works up until iTunes tries to verify it, then dies.

I’ll try again tonight :slight_smile:

A few tips for overcoming errors during the iTunes restore process can be found here.

Thanks James,

 

The hosts file change was one thing - I ended up with something in there from seas0npass (I assume, as I dont use any othe others) point to a 72.something address. Removing it adds it back in next time I run seas0npass (it’s mentioned in the seas0npass log file too)

Other than that, I’ve followed all the other things on there… I even restored the stock apple firmware (via Dropbox from someone else here, as my connection is still serving up the 116meg or 286meg version), which worked fine… so worst case, I have a working, up-to-date ATV2 to play with :slight_smile:

Ok, if Seas0nPass is re-adding it, you can uncheck the ‘Use Cydia signature server’ option found in the Seas0nPass > Preferences. This will prevent Seas0nPass from adjusting the hosts file in the future.

 

BINGO. Unticked that, and it worked first time. Thanks James! (Now to buy ATVFlash(black))

Great! Glad to hear you’re up and running. :)

 

And 10 mins later I’ve bought, installed and am configuring ATVFlash. Nice :slight_smile: