Problem Restoring

I have an Apple TV i’ve had jailbroken for quite some time.  I was holding out on the 4.4 update until the untethered jailbreak came out.  Since it was out I figured i’d give it a go, but start off with a fresh install of 4.4.4 instead of a jailbroken 4.4.4 just to make sure everything was running smoothly.  (I’ve been running 4.3 or older, not sure for a long time now)

Restoring through itunes is when my problems started.  It detected the ATV just fine, i click restore and it downloads the newest update and begins the restoration process.  I hear the USB connection/disconnection sound a few times and then iTunes comes back with an error 14.  OK Fine, i’ll give it a go on the iMac sitting right besides the Vista machine i tried it on.  No go, although this time with an error 1611.  

At this point I’ve tried every different plate of USB ports on the Vista machine and every USB port on the iMac.  Unfortunately I only have one micro cable because the only use for one i have is the ATV (thank god for changing standards, i have about 200 mini USB cables sitting in a drawer unusable…).  I only use AVG for Interenet security and i’ve disabled all it’s security features (although I’m currently trying a restore post-restart for the first time).

I’ve yet to have any luck.

Please help!!

 

PS: the restore i was attempting while writing this up failed with an error 1604.  Joy.

I might try a new USB cable in the morning, but at this point I’m pretty frustrated with the whole deal and I’m gonna call it a night.  :(

Since you had previously JB the ATV2 , i belive you have to make sure you get into DFU mode before attempting the restore even if it is just to put back the standard Apple firmware. It sounds as if you may have simply plugged the ATV2 in and done the restore without the extra steps needed to get into DFU mode?

 

My understanding is iTunes puts it into DFU mode when performing a normal restore.  That said, I DID put it into DFU mode while running seas0npass.

turns out the replacement cable worked sort-of… it failed the first few times but I then remembered a trick from the last jailbreak process… I applied upward pressure against the micro-usb cable/port during the entire restoration process and everything worked great.

I’m fairly certain i tried that with my original cable, so it may be a combination of both the new cable and the upward pressure, i’m not sure.  But i’ve now successfully restored to the standard 4.4 as well as restored to the jailbroken 4.4 (via Seas0nPass).  So all is well!!