Problem jailbreaking to 4.4.4

I am having a really strange problem. I have jailbreaked a couple of atv2s on my computer to version 4.3 (if i remember correctly) using seasonpass and everything has been working smoothly. Until what I suspect, a friend of mine mistakenly updated his ATV via the ATVs own menus. He has no clue as to what he has done. 

The atv was simply flashing the front light and screen was black, sometimes the apple logo showed but others not. I plugged it in to my computer and did a restore in iTunes, to 4.4.4 it seemed to work correctly after this. But when I try to jailbreak it using seasonpass, no luck. It goes into DFU-mode and creates the ipsw correctly, however in iTunes I am getting 1602, 1600 and lots of errors when the script is trying to restore. I have tried the same process on 4-5 different computers, both macs and pcs but still same outcome, read the forums about tips on the powercord but same thing wether its plugged or not. Even bought a new USB-cable but it didnt help either. Might add that I have successfully jailbreaked another atv2 to 4.4.4 using seasonpass on the same computer. So it seems something is wrong with the ATV2 in question. 

I have no clue as to what I should do with it? Since nothing seems to work. If you guys have any clues or ideas I would be thankful.

Sorry for the bump, but I am still having the same issue and can’t seem to fix it. Worrying if it is broken…

Any ideas are appreciated…

I had the opportunity to jailbreak such an atv2 of my friend. He was struggling few days, so called me. But really, I wanted to take it back to the shop.

Nevertheless, we found steps, how to help it.

First, try the other steps how to enter DFU - with power cord out on usb cable only reset atv2 first, then start DFU, when DFU entered, plug the power cord back. If still not working, use package created by Seas0nPass, but enter DFU mode with sn0wbreeze and iREB mode.