Problem Infuse with FTP streaming

Hello,
I have a Seedbox in order to stream video and I used Webdav protocol to play video via Infuse and an AppleTV, Ipad or Iphone, but since this week, webdav protocol have been removed from my seedbox provider and I must use FTP instead of webdav protocol.
Unfortunally, I have a problem with FTP protocol in Streaming. I can see folders and movies on my Seedbox, but when I play a video, I’ve got an error message :
I’m sorry but it’s in French, “Une erreur s’est produite en chargeant ce contenu”, that means “An error occurred while loading”.
I tried on 3 others devices, but same error message :
On AppleTv I did a total reset and installed the last version of IOS & Infuse 5
On Ipdad, I have the last Infuse 4.3.6 PRO,
On Iphone 6S, I installed the last version of Infuse 5X Pro
I also tried to swap from my Internet provider to the 4G Mobile Internet, but same problem.
I also tried by LAN and Wifi.
Sometimes (1 time out of 15), I can play a video, but on the next attempt, I have this error message again.
Do you have any idea what the problem might be ?
Thanks and best regards
Céline

Diagnostic Report : S17Z2

I have the same problem…

I’m having the same problem. It won’t play on my iphone 7 plus or the apple tv 4