Problem fetching metadata for series

Have you managed how to naming this series?
I have tried the NC_Bulleyes advice but without success.

Have you tried “V the Series 1984 S01E01.mkv”?

Yep :frowning_face:

Did you do an edit metadata after the change and select the right show?

Yes. I edit the metadata and manually pick the series since there’s no matches found.

Okay, just tried it out with this naming and file structure
V The Series 1984 name and structure test
It worked without me even having to do an edit metadata

And this metadata

1 Like

The reason @NC_Bullseye ’s filenames work and the official title doesn’t is because when shows have very short titles (and none is shorter than “V”) there’s a whole lot of potential matches to trip up the algorithm — and TMDB’s algorithm doesn’t prioritize exact matches over matches that contain the all the words in you search but also a few more; or original release dates over later regional releases dates when somebody started selling a DVD re-release in Palau.

So the best thing to check (when exactly matched Name and Year don’t work) is the “Alternative Title” field. These usually exist because someone before you also couldn’t get the thing to work with their preferred name.

They usually have more words — more data points with which to more accurately make a match — or some different words that don’t cause conflicts with other titles.

Or they may be titles in another language. (Doesn’t matter if you use a French filename, you’ll still get English metadata — or metadata in whichever language is your Infuse default.)

Notice here, for “V (1984)”:

Well short name don’t always have problems so don’t take that as the golden rule.

This also works perfectly without having to do an edit metadata.
v 1984 also works
This provided the exact same results as above.

I never said it did. But when my titles don’t match, that’s the most common correlating factor.

I’ve also found that once Infuse accepts a match, it is much more likely to accept that match again.

And when searching TMDB via their web interface, I notice the same.

Whether that’s because they use tracking cookies or log IPs or simply because my recent search pushed my desired result to the most popular spot, I don’t know.

I have spent an insane amount of time making sure every title I have is recognized correctly. I have industrialized a process of manually browsing through the nearly 5000 some titles in my collection hunting for unfamiliar titles and unfamiliar artwork after importing my library with my local .nfo and poster images hidden from Infuse (by changing their file extensions).

I’ve found that sometimes titles that used to work stop working, and others that didn’t work in the past start working. I can almost always find out why the identifications go wrong by examining various metadata sets at TMDB. Very rare these days I can’t figure out the conflict that causes another title to hijack my desired one.

Does this naming pattern work for files hosted on Google Drive? Maybe that’s the problem.

Did you duplicate the way I showed with the show folder and then the season folders inside and then the episode files in each season folder?
V The Series 1984 name and structure test

This should work on Google drive but you may have to refresh the metadata to get the new names on Google drive to be recognized.

Yes, I’m using the exact same filename pattern =(

This may be a long shot and it may be the font that is throwing me off but it looks like your “0” in the “S01E01” could be the letter “O” instead of being a zero. Again, this may just be the difference in font but I’ve seen it happen.

One other thing, in the series folder you have () around the year and in the files you don’t. I’d suggest you remove them from the series name for the main folder.

And when you have done that could you go to settings > Library and click refresh metadata?

I can confirm that there’s no “O” in place of “zero” in the episode/season part of filename.
I also have removed the () from the folder name and refreshed the Library metadata.

And I’m assuming it still doesn’t work?

In settings, you’ve got the “Metadata Fetching” toggle ON, and the
and “Embedded Metadata” toggle OFF?

It’s very unusual not to get any potential matches when you try to update metadata.

1 Like

Turning the “Metadata Fetching” toggle to ON do the trick! :smiley:
Since I use custom metadata for all my movies, I let the “Embedded Metadata” on, but it doesn’t afected the series at all. So, thank you!

1 Like

A post was merged into an existing topic: Metadata wrong language

Unless you’re actually embedding the metadata into the video file you will want to leave the embedded turned off. It really slows down the scans looking at every file for internal metadata.

1 Like

Cool! Glad to help get you sorted!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.