Problem Connecting to WD MyCloud Home from Mac

Ha, after months of ease, all the sudden I cannot connect to my /public folder as well. I think it has to do with a MacOS update. My ATV inFuse is still connected to my library on the WD Home, but I cannot connect to it from my desktop in order to add new material using the above mentioned (by me!) method of connecting directly to the hidden public folder. I will start posting at WD and anywhere else I can think of, but as usual, thoughts here are appreciated.

I have tried from multiple devices and after inputting the credentials (I have tried my WD Home creds as well as admin/admin, the MacOS response is “check the server name or IP and try again, if you continue to have problems contact the system administrator”

Just spent some time with WD support chat, here is what I found out and a working solution.

The My Cloud Home Public share cannot be seen on macOS computers.
Only the TimeMachineBackup share can be seen in macOS Finder.

Cause:

The My Cloud Home Public share supports the Common Internet File System (CIFS) connection method.

IMPORTANT\ 35pxx45px Important:

The My Cloud Home Public Share is designed and implemented for Windows File Backup. It is not designed for local LAN storage access. Although is can be accessed on macOS using Common Internet File System (CIFS), it was not designed to be used as local LAN storage for Windows or macOS. Please use WD Discovery and the User Private Space for your My Cloud Home content storage needs.

Solution:

Connect using macOS (CIFS)

  • The Common Internet File System (CIFS) tag must be used for connecting to the Public Share on macOS
  • The connection must be made as the macOS Guest user

| cifs://guest:guest@MYCLOUD-XXXXX/Public | CORRECT |
| cifs://guest:guest@/Public | CORRECT |
|afp://guest:guest@MYCLOUD-XXXXX/Public| INCORRECT |
|afp://guest:guest@/Public| INCORRECT |
|//MYCLOUD-XXXXX/Public| INCORRECT |
|///Public| INCORRECT |

silsurf

5m

Roy S: Please be informed that you can map your WD My Cloud Home Public share using the link below:
https://support-en.wd.com/app/answers/detail/a_id/30614
Henry: up until recently I was logging in as a registered user using my WD Home usr/pass?
Henry: The guest access did go through, So I am able to log in, but wondering what changed?
Henry: And really wondering if WD can please make access to the public folder easier for us Home users?
Roy S: Please be informed that since the drive does not have dashboard and you are trying to map the public share so you don’t need to login with the registered user. Please try to map is using Guest and let me know the outcome.
Roy S: Please be informed that this is issues is only due to the recent changes in the macOS Big sur. However, the public share as as easy to access like a private share in any other macOS.
Henry: ahh, I see. But I cannot access it from the My Cloud Home ?
Roy S: Are you getting any error while trying to login to your My Cloud Home device?
Henry: NO, I can log in just fine, but There is no path to the public share?
Roy S: Please be informed that you can access the public folder only when you’re connected locally. You cannot access the public folder using MyCloud.com.
Henry: also good to know, thanks very much!
Roy S:

1 Like