Problem ATV2

Sorry, i have an ATV2, i did the jailbreak in 2011 of the 4.2 or 4.3 version. Actually I want to pass to version 5.2. I downloaded the last version of  Seas0npass, I did all passages and a the end, seas0npass don’t open itunes to complete the process. How can I do?

I also tried to download the file .ipsw of 5.2 version from internet and upload with itunes on the apple tv but there is always an error (11, 21, 1600) 

If you don’t already have backed up signatures (shsh blobs) for other versions then you can’t upgrade to them unless Apple is still signing them.  The only jailbreakable version Apple is still signing is 5.3 so without the saved blobs you have 2 options…

  1. stay on version 4.2 (or 4.3) which is an untethered jailbreak

  2. upgrade to version 5.3 which is a tethered jailbreak 

I have saved blobs and still cannot activate.  Install goes just fine, but activation fails, once plugged into the TV.  Tried on 4.4.4 and 5.0.  Maybe I just need to try all of those which are untethered.  My computer and TV are in different rooms so cannot do tethered.

 

I wanted to pass to 5.3 but seas0npass after download .ipsw file say me “firmware restore failed” and didn’t open itunes to complete the restore.

If i choose to stay on version 4.2/4.3 how can i do? beacouse when I connect ATV with HDMI to my tv on the display there is the Itunes logo

If you’re using a MAC you might want to borrow someone’s PC instead so you can run iFaith to search for and try saving your blobs for 4.2/4.3 since those versions can be jailbroken untethered. 

In regards to performing a 5.3 tethered jailbreak you should also use a PC to run Seas0nPass for Windows because I’ve heard others here are having problems doing this on their MAC.  And you should do this before Apple decides to quit signing 5.3 which could be at any time.

Also, I’m curious why you didn’t just stay on 4.2/4.3 in the first place?