Probably losing my mind (JB doesn't seem to work)

Hi there. Earlier in the week I convinced a friend of mine to trade his ATV2 for a new ATV3 I bought (he has no interest in jailbreaking, so it was win/win).

I’ve been trying all day to get this thing jailbroken, and have come across (and seemingly troubleshooted my way through) several errors.

Twice, Seas0npass and Itunes finished everything without a hitch. Upon connecting the ATV2 to my tv, there was no red FC logo. I thought I missed it somehow, but found myself unable to SSH into the ATV to install XBMC. It either times out (with PUTTY) or gives me other errors with different SSH programs.

 

I am currently in the process of reinstalling Itunes and downloading Seas0npass all over again to see if it might be kind enough to work this time. I have tried 3 different micro USB cables, and every USB port on my PC. They all seem to work fine (the unit has no trouble keeping power with just the USB connected). Seas0npass is currently doing some downloads, and I expect I’ll end up with another horrible failure on my hands, which is why I made this thread. I’ll report back with whatever error code I happen to get this time, and I really really hope someone is kind enough to help me out.

My latest bout with the box goes as follows.

I reinstall/re-download everything involved with the jailbreak.

I run Seas0npass and let it run all the way through until “preparing apple tv for restore” hangs for way too long, resulting in an error (1604).

I download and use iREB, to ensure that the ATV is in the proper state during restore. I shift click restore in iTunes and choose the file Seas0npass created.

The restore goes off without a hitch. I connect to the TV (choose language and connect to my network once more). Still no FC logo where settings should be, and I still can’t SSH into the device.

It is running 5.0.2, and is most certainly an ATV2. Any idea why my jailbreak seemingly refuses to stick to the device?

after using seas0npass and booting up and not seeing the firecore logo did you do a reboot of the apple tv and check again? I notice sometimes after the apple tv has been off for a long time it will boot up but with no jailbreak software showing, no firecore logo nothing. I had to hold the down arrow and menu button on the remote to force a reboot then the firecore stuff appeared

just did four apple tv jailbreaks a few minutes ago so it’s working

OK, I’m having similar issues. I am currently running Lion (10.7.5), iTunes 11.0.1, and iOS 5.0.2 (5.1.1 9B830) on my ATV2. I did a factory restore to 5.0.2 without the jailbreak. Ran TinyUmbrella to store shsh. Ran SeasonPass, which downloaded the 5.0.2 ipsw and then created a new ipsw with SP in the filename. I hooked up my ATV2 via micro usb and SeasonPass automatically opened iTunes and ran the restore using the newly created ipsw file. There were no errors or any other issues. However after unplugging the ATV2 from my computer and reattaching it to my tv, it takes a longer time than usual to boot up and there is no FC logo on the screen. I tried to SSH via terminal and Cyberduck. Terminal tells me “connection closed by remote host” and CyberDuck tells me “premature connection close”. I’ve tried unplugging the power from the ATV while it was still plugged into the tv to do a reboot and nothing changed. I also tried a force reboot as mentioned by dknight using the remote with no change. Any other suggestions? Thanks in advance.