Pro 5, Metadata download failed to get updated content from TMDB

When meta data language is set to non English like Chinese (zh-CN), Infuse 5 refused to re-download content (title, poster) after I modified at TMDB.

I tried to download the same title from an iPad which has Infuse 5 fresh installed, it downloaded correct title and poster.

I tried to re-downlaod from Infuse 4, it refreshed.

I tried to call TMDB API, it returns correct result too.

Here is a sample,

I modified movie “Cold War” on TMDB, updated zh-CN title name and poster. JSON result is correct, but in Infuse 5, it still shows previous title name and poster no matter how many times I tried to Edit meta data.

{ "adult": false, "backdrop_path": "/g0Gq4XWYBL7gor64nYMAFEypHHO.jpg", "belongs_to_collection": { "id": 404302, "name": "寒戰 (系列)", "poster_path": "/8eWnwSJbHT9RVhVIgVKJ6tNwkp.jpg", "backdrop_path": "/rXnsChrweFItmkA5wPtq4WQdUt6.jpg" }, "budget": 0, "genres": [ { "id": 53, "name": "惊悚" }, { "id": 28, "name": "动作" } ], "homepage": "", "id": 137409, "imdb_id": "tt2186715", "original_language": "cn", "original_title": "寒戰", "overview": "作为亚洲金融中心的香港被称作“最安全的城市”,岂料警局接到一通匿名电话,对方声称劫持了警队的一辆前线冲锋车以及车内的五名警员和武器装备。此次事件引起了香港警队高层的高度重视,适逢处长(王敏德 饰)出访国外,此时由鹰派人物行动副处长李文彬(梁家辉 饰)与年轻的管理副处长刘杰辉(郭富城 饰)一起负责这次案件,并将行动命名为“寒战”,李文彬任总指挥。李文彬的儿子(彭于晏 饰)也是人质之一,刘杰辉因此对李文彬父子产生怀疑。与此同时,匪徒展开了进一步行动:警察被杀、爆炸案频发……到底是谁在将整个警队玩弄于鼓掌之中?香港真的是“最安全的城市”吗?", "popularity": 1.469456, "poster_path": "/yYyRZs82wdgzwxu1UEvDF9PvCFv.jpg", "production_companies": [ { "name": "Edko Films", "id": 10284 }, { "name": "Irresistible Films", "id": 47037 }, { "name": "Irresistible Delta", "id": 82612 } ], "production_countries": [ { "iso_3166_1": "HK", "name": "Hong Kong" } ], "release_date": "2012-11-08", "revenue": 0, "runtime": 0, "spoken_languages": [ { "iso_639_1": "cn", "name": "广州话 / 廣州話" }, { "iso_639_1": "en", "name": "English" } ], "status": "Released", "tagline": "", "title": "寒战", "video": false, "vote_average": 6.3, "vote_count": 34 }

the same happened on TV shows, unable to re-downalod poster fro TVDB. For example Planet Earth II, I got the poster with Spanish Character “Season 1” shown on Poster, but TVDB site does not have such strange poster.

there’s only a Spanish cover uploaded in season 1. I have the same problem with another TV Show, it also shows Spanish covers… So you can try to upload a cover in the language you need, but it will still show the wrong one in the season overview. The cover in your language will be shown once you open the season. Apparently it’s a bug. Don’t know where though, in TVDB or in Infuse.

I uploaded English version of Season poster to TVDB, but Infuse still downloaded Spanish poster…

Pro 5 just refuses to download updated poster and title… the only way to get correct post/title is, completely reinstall Pro 5.

I must be crazy, I re-built 1000+ titles in different meta data language just because few wrong posters…

Hi, guys!
I think that reinstall fully Infuse just for some posters is not good idea. May be it would be simpler to embed necessary posters to that files which have incorrect posters in TVDB/TMDb? After that you should go to Infuse’s Settings and switch on “Embedded metadata”. After → long tap on folder with tv show/movie which metadata is incorrect and choose Embedded metadata. Infuse will download all existed metadata items from file(-s). After → long tap again → choose online metadata. As result, in reality, you will have COMBINED metadata (all embedded items of metadata will be from file, others - from TVDB). On my opinion it is not so logical but it is a fact. It works for me at least…

NB: In this post James proposed similar solution for similar problem: Not showing thumbnails on some movies - #9 by james

unfortunately it doesn’t work for me. When I turn on embedded metadata it sure downloads the embedded covers, but then it doesn’t group the episodes in season folders. And as soon as I chose online metadata again, it replaces the embedded covers with the “wrong” ones from TVDB. At least grouped in seasons :frowning:

I faced with this situation too. But if the first step would be online metadata, second - switch on embedded (do not switch off online, keep them in ON together) and correct just for wrong items, not for all items in your Library and/or Favorite, just for wrong items through long tap on them. And if you don’t forget after choosing online metadata for these items again through long tap too, it should work, and TVShow view with episodes grouping should be saved for tv shows too. At least Infuse 4.3.2 did not redownload any metadata’s items if they were existed early from file like embedded. But I haven’t tried Infuse 5 on ATV yet. I only bought subscription (just for support developers) and I’m going to try it on ATV on weekend only. May be some differences between versions?.. If I can try Infuse 5 on weekend with fully reconstruction of Library (Favorites) I will write obviously about results.

not only Title, Poster, but Episode image is also refused to update, once you downloaded, it is permeant then. Next time I think I shouldn’t send the movie to NAS unless TVDB or TMDB has all meta data correctly entered…

@james, can we expect a fix in next version?

v5.0, 5.0.1 didn’t update title, poster, but it still updated description if I switched meta language.

now v5.1… didn’t update description even.

i have no idea what’s the idea behind this behavior, when a movie meta data was fetched by infuse, it was english only because TMDB didn’t have Chinese meta entered, so I entered Chinese version in TMDB, but the correct info will never be used by infuse.

@James, can you please response this?

it still happens on v5.2

This problem seems to be fixed in 5.2.1 :slight_smile:

Thanks @James

problem appeared again in 5.3.1!!!
can’t download meta data again after filled correct meta data @ TMDB

Can you provide a bit more info on what’s going on? Are you making changes at TMDb/TheTVDb, and those changes are not appearing in Infuse?

Each service uses heavy caching, so it will usually take 1-2 days for the updated details to be available to apps like Infuse.

It is basically repeating the same story I have mentioned in this thread.

  1. I uploaded a (Chinese) movie to NAS

  2. In Infuse I changed meta data to Simplified Chinese

  3. Fetched meta data of this movie, it is English.

  4. I went to TMDB, there is no Chinese meta data for this Movie, so I added.

  5. I waited 1 hour, tried with TMDB API to make sure the Chinese meta data is available

  6. I went back to Infuse, Edit, it still downloaded English meta data.

  7. I waited 10 more hours and tried again, still no Chinese.

  8. I created a local xml, Edit and pointed to local xml… Infuse simply ignores local xml in this version!

  9. Additionally, Infuse never tried to re-download Backdrop image in any of previous version.

So, what am I supposed to do with the wrong meta data?

And I don’t understand what your meant by heavy caching, If someone “Edit” meta data, he intents to update something, why Infuse gives a ‘cached’ data?

Can you make it simple, just to re-download EVERYTHING of a movie (title, casts, description, poster, backdrop etc) when Edit is used?


this issue existed since v5 until v5.2, it was fixed in v5.2.1 (except Backdrop image) now appeared again in v5.3.1

Caching simply means there will be a delay before Infuse has access to changes made on TMDb/TheTVDb. This caching is built into each of these services to allow for faster performance, and unfortunately we don’t have a way to override this from within Infuse.

In our experience, changes made on either of these services will be available within 1-2 days.

No it didn’t, the first time fetching was 52 hours ago, i tried multiple times after that until just now, still English.

I believe you have many ways to differentiate if a HTTP call is triggered by backend scanning or Edit button so you can decide to use cache or override cache. I meant, there is no reason for someone to wait for couple of days in order to correct the wrong meta data.

70 hours passed, it still downloads English info.

This doesn’t look like caused by caching, I guess something wrong in the code when Language is not English.

I’ve just tried it here, and everything seems to be working as expected.

Do you have the Metadata Fetching setting enabled? What about the Embedded Metadata option? Do you have any external XML/NFO files present for this title?