Primary External USB Not Performing as Primary Drive

  Hi there,

I've scoured these boards and tried every available solution, but haven't been able to fix this problem:

  • I'm trying to use a new, Seagate 2TB USB as my primary storage, and when I step through the processes posted on these boards to make that work, it seems to work — until I open iTunes and my Apple TV profile shows 32.84 GB.

I have done the following things to troubleshoot. None have been effective:

  • I bought a new hard drive (original drive was 3TB, but seeing that size was not endorsed, I replaced it to see if that was the problem. It was not).
  • I have factory-restored the Apple TV, run all the updates, and reinstalled Apple TV Flash. I'm still experiencing the same results.
  • I have re-run the Smart Installer. 
  • I have followed the letters to a 'T', being certain to Sync my Apple TV before redirecting to the External Storage, even though there's nothing on my Apple TV to back up. It's still ineffective.
  • After switching to External Mode, I synced a test file (a podcast) to see if it was copied to the External drive or the Internal drive. It seems to have been copied to the Internal Drive — despite the fact that the Maintenance->Settings say I'm operating under External Storage.
  • Using the NitoTV->Files menu, I can see that my External Drive is detected by the device, so the USB port is working.

Initially, I thought the fact that I was trying to add a 3TB drive to my Apple TV freaked out the device and just had it registering the External Drive as 32GB, but that's clearly not the case. Also, one last curiosity:

  • Before reformatting the 3TB drive, when it asked me if that was the drive I wanted to select, it said it was a 2.9GB drive. Obviously I thought that was strange. Now, when before reformatting the 2TB drive, it doesn't even ask for confirmation in advance, so it doesn't even tell me how large it *thinks* the drive is.

Thoughts are appreciated... I've had a very hard time making Apple TV Flash do what it's supposed to do, and I'm getting very frustrated. 

Thanks!

 

Some drives come with security/backup software pre-installed which can cause issues with the AppleTV.

Your best option would be to remove this software using the software cd that came with the drive or by downloading the software for your drive here: www.seagate.com/ww/v/index.jsp

 Would zeroing out the drive work too? (I'm currently in hour 4 of 22 to do that)

 And actually, since no disks were provided with the drive (everything was pre-loaded on the drive, and they're long since formatted off), I'm hoping zeroing out is an effective solution.

Since my last posts, I have taken the drive off zero-ing out, and tried to do this. Unfortunately, there is no software to download or fire up on a disk that allows you to remove any default installed applications or deselect security/backup or power settings.

There is a diagnostic tool which, allegedly allows Mac users to make the drive match the System Preferences. According to Seagate, if you've got this diagnostic installed (they didn't even say running, but I was running it for good measure) and changed your system preferences to never put the hard drive to sleep, the mounted Seagate drive would follow suit. I find this hard to believe, as the only functions within the diagnostic tool itself were testing the drive, toggling the LEDs.

I guess I'm going to have to zero this drive out and see. Seagate says that should not affect the power settings on the drive, for whatever that's worth. Maybe it will, maybe it won't. Maybe it will remove whatever lurking files are in there screwing up initializing the disk.

After that, it's back to best buy for another brand. A shame. This Seagate Drive seems solid.

 In addition, I've dismounted it from NitoTV and then remounted it ---> a lengthy process, but ineffective.

I've also reformatted it for MS-DOS, plugged it in and tried to set it as External Primary ---> another a lengthy process, that caused the AppleTV to hang both on the 'copying files' page and at the reboot Apple logo, but also ineffective.

I'm at the end of my rope here. It looks to me like the only solution (if it even works) is to zero the drive out. Unfortunately, I can't leave my laptop stationary and teathered for 22 hours for the next three days, so it will have to wait. 

 

If anyone has any other suggestions, I'd love to hear them. Nothing has worked so far.

Unfortunately zero-ing out the drive usually will not work. Often times (especially with WD drives) there will be a hidden partition which cannot be removed without using the included software.

Was your drive listed in that link I previously provided?

It was, but the software that Seagate provides for download does not allow for removal of any security features. It's basically a diagnostic tool that ensures the drive is functioning properly. 

So, no other suggestions?

The only thing I could recommend would be to give Seagate a call to see if there's a way to remove their security software.

Pre-installed software like this lets them advertise additional 'features' but in the real world if often creates more problems than it solves.

Thanks. I already spent way too much time trying to sort this issue out via their online chat tech support. They are really Mac-unfriendly, which is a shame, because I like the drive. It seems solid and quiet.

 

I'm going to return this to Best Buy (yay 30-day, no questions asked return policy!) and either get a new one and try to disable the security software in-store with my laptop. Or, if they won't let me do that, I'm going to just get a MyBook, since you guys seem to endorse those models.

Okay, I've gone out and purchased a new drive from your recommended list (WD MyBook Essential), and it still does not work. Same problem, same results and this time I was able to uninstall the "Virtual CD" software included on the drive before I used it with AppleTV Flash.

There must be something wrong either with the processes outlined to execute this option, or I'm missing some minor but important step. I have ATV Flash 4.2.1, I have run the smart installer, but still cannot get the AppleTV to connect my external USB as the primary drive. It is, however, being detected as connected to the device as an external drive.

If we're not able to resolve this, I'll have to ask for a refund. I don't want to do that, but I bought this software for this specific function, and it's not performing as advertised.

Please help — it's my preference that we get this to work!

Thanks... 

Do you know the format of the new drive? Many of the new drives (other than those specifically marketed for Macs) will be formatted in NTFS format which is not supported by the AppleTV.

It was Fat32 when I bought it. I uninstalled the Virtual CD software and tried to make it the Primary drive with ATV Flash, but it didn't detect.

Then I formatted it to Mac OS Journaled and tried again. It still didn't detect.

Any idea on this?

What size is the drive? What name does the drive currently have? When connected is the drive visible in the nitoTV --> Files menu?

I named it "MediaUSB" when I formatted it to HFS, and it is visible on nitoTV as 1862GB

Tried again tonight with a brand new Iomega SSD 120 GB drive. Same results.

The problem is that the software is not initiating the format sequence and then linking the Apple TV to the drive as primary storage. It just doesn't work. 

Was this issue ever resolved?  I'm having the same problem with an WD Essential 1.5 TB hard drive.  It looks like the AppleTV recognizes the HD but iTunes does not.  iTunes is still showing 32GB.

need to format the drive as Apple HFS+ file system. It fixed mine.