Pressing home causes a problem when returning to app

When I am playing a file and press home on the remote, it will go home.

However, when returning to the app it tries to return to where it was playing and almost always fails. I get an error instead of it going back to the menu.

Is anyone else seeing this issue?

I tried 30 + different files multiple times and it never failed so I couldn’t duplicate what you’re seeing.

What is the version number of Infuse you are using? tvOS?

What are you streaming from, NAS computer, etc?

What protocol, SMB, FTP, DLNA?

How are you connected, WiFi or Ethernet?

13.5 tvOS, latest infuse.
streaming from NAS over SMB using Ethernet.

It’s consistent. I play a file. While it is playing I press home. I then come back to infuse a few minutes later, it attempts to continue playback and fails to do so and I get an error message.

1 Like

What version of Infuse ( there have been a few updates lately and it helps to know the actual version number sometimes), and “a few minutes later” means how long? 2 to 3, or 10 to 20, etc?

What model NAS?

I’m using version 6.4.9
NAS: Synology DS1019+ (IMO that doesn’t make a difference).
Tried a few scenarios - pressing home while playing, then returning to infuse works fine. Even pressing home while playing and opening Netflix works. However, if I open a few apps that show video and return I get the error (“an error has occurred” with the Close button).

I think that it’s enough time or something with enough memory requirements that tvOS kicks the app out or something like that.

IME people run the gambit of what they call a NAS, everything from a well know brand like Synology to a cobbled together Win 3.1 Compaq with 20 year old hard drives. It helps to know.

I do have to ask, why not exit the video a bit more gracefully by hitting the Menu button and then the Home? That gives Infuse the cue to log the exit time and it should be there when you start that video again regardless of what you’ve done in between sessions of using Infuse.

I don’t think the issue has anything to do with the NAS, I think it’s something to do with tvOS doing something to infuse if it needs a resource.

Great question about exiting infuse gracefully. It’s a bit complex, but the reason is that I am using an automation system (smart home). Turning on the ATV is a bit problematic as the protocol was changed between tvOS 12 and 13, so I have to use Home as a wakeup signal for the unit.

If something is already playing, it sometimes causes the error to trigger…

In your case I don’t think there is any problem with the NAS but not knowing the info as to model I asked for I had no way to eliminate it.

Maybe even more of a reason to use the Menu button first, and then exit Infuse with the Home button. I wake my ATVs with the Home button exclusively and have never had an issue with resuming a video I was watching. The bonus to me is that the show you exited out of with the Menu button is the first one listed in the “Watching” bar at the top of the home screen when you launch Infuse the next time.