Possibility to play files directly from external drive using USB-C on iPad?


I am just curious because in iOS 13 we will finally be able to plug in an external disks for eg. an SSD using an iPad with USB-C and acces it using the Files app. Will we, after iOS 13 is released, then be able to play files directly from the SSD without the need to first copy it into Infuse? :slight_smile:

I am currently using iOS 13 public beta 4 on my iPad Pro but for now there does not seem to be a way to play files directly from the SSD (I guess Infuse has to make some adjustments). There is at least the possibility to copy the file into Infuse but this does not seem to work for me at the moment.


1 Like

Seconding this question. Curious to know whether iOS13 / iPad OS (13) allows apps to read/playback files on external storage DIRECTLY (without having to copy the file into the local storage/Infuse container

So I downloaded the iPad OS 13 Beta 4 and tested out some of the functionality of the “Files” app that comes standard.

When I copied a file from my NAS to a newly created folder on either the iPad or within the JumpDrive attached via USB, it doesn’t allow “open-in” / direct playback within most apps you would expect (including Infuse). It will only play within the native player in the Files app, which means that it only works for limited file formats like m4v and will not give any options to .MKV files aside from copying it into the container folder of a different app (i.e. Infuse)… so you’re stuck moving around most files from the JumpDrive back onto the container folder for infuse if you’re attempting to use the native Files app in iOS13. In this regard, the Files app, even in iOS 13, is fairly hobbled unless you’re attempting to read from the USB drive a super standard file like a .mp3, .jpg, or a .m4v format (you also cannot change the file-name extensions).

The only way I see this working to avoid copying files back and forth is if there’s some API that is developed within a third party app such as infuse that allows it to directly read from what is recognized in the Files app (i.e. the JumpDrive) so that it plays directly within the app.

So I guess this is the remaining question to Infuse Devs… is there / are you planning on embedding an API that allows direct access of iOS 13 file locations, including USB locations, for direct playback?

Hi Patrick,
According to this thread:

Beta 5 solved it. I am not in the beta program so can you try it?

We’re currently looking into the options we have available here for accessing USB drives in iOS 13, and hope to have more news soon.

Thanks James :slight_smile:

@Carlos51 I tried it but the copy to Infuse function is not always available for some reason and if I press it nothing happens. ?


We’ve been looking into this, and USB drives can be accessed directly via the Files app integration in Infuse. This will be available in the upcoming 6.1.6 version.

We’re still digging into a few things, but as of now it looks like the files will need to be copied into Infuse before they can be played.

This feature works for me on ipad OS 13.1 beta 4. Connect hard drive select open in infuse> Play

Game Changer!!!

Only question i have is infuse showing 6.48 GB of storage being used in settings even though there are no files in the app.

Settings where? iOS settings or Infuse settings and what path to find this?

setting>general>ipad storage

I’m guessing that’s the cached file eating up space but not sure how to confirm. Any way to tell if it’s actually playing directly off the drive or if it’s copying and playing off the device?

What do you show in Infuse > Settings > General > Metadata?


That’s not very much, how big is your library? Movies? TV Shows?

0 files in my library. empty. I was only playing files off the hard drive. “play” option. Not save and play. (the save and play option does work but i deleted the files it copied)

So when you go in Infuse Settings > Library is shows 0 for both Movies and TV Episodes and Others?


I’ve never seen a 0 content so I’m not sure where to suggest you look. It almost sounds like there must be some file in the files app that it thinks is Infuses. I’ll back out and see if someone else has run across this.

i copied a file from the hard drive to infuse. Infuse folder showed up in “on my ipad” but only the file i just copied is in there.

even though i deleted the file i copied (though the files app) usage still increased to 7.38gb.