Populating file Data in Sapphire

I seem to have a major problem with Sapphire, I can fetch both TV Show data and Movie Data and this completes without any problems (progress bar completes). When I go on to Populate file data or Import all data this is where the problem begins. Sapphire will run through the directories but then stops after populating only a few movies, the progress bar gets to around 10% only and stops. I even tried removing the movies where shown where the progress bar stops, but it just gets to the next movie in line and stops again.

This same issue has happened ever since installing Sapphire but the data would still get populated. With the latest version of ATV Flash data is no longer populated and my TV Shows and Movie directories are almost empty. I have tried deleting both the Metadat.pilist and moviedata.pilst but this has not helped. I even renamed the Sapphire folder in order to start afresh and the same issue occurs. Anyone have an insight on how to get this working correctly.