Poor quality downmixed audio

I have noticed recently that the the audio quality of infuse appears to be significantly worse when decoding and down-mixing multichannel sources (Dolby/DTS or LPCM) vs other apps/sources.

I use a 2.1 setup, with the ATV decoding everything in 2.0 24/16bit 48KHz LPCM. Following the 7.3.4 Infuse release, the LFE track is also now mixed into the 2.0 stereo down-mix from multichannel tracks instead of being discarded.

It is hard to describe exactly the issue I am hearing and I have no way to do a direct digital recording to compare, but there appears to be some severe clipping and distortion in the LFE, along with a generally narrower sound stage and more “compressed” sound with reduced dynamic range.

An obvious example of the issues described is with the Dolby Amaze demo (available here) using either the standard DD or True-HD Atmos version. At around 00:36 there is a bass rumble, which when played in Infuse sounds terrible with significant clipping and distortion. Also around 00:20 there is a sound that pans left and right, which in Infuse sounds very narrow.

If the same file is played in MrMC (which can also mix the LFE on down mix) the audio quality is noticeably more dynamic, with no clipping in the bass and the full dynamic range maintained. Given this is an app on the same ATV with the same settings then the problem is with how Infuse is handling the decoding and down-mix. Even using VLC (which drops the LFE) the quality is much better and more dynamic than Infuse.

I have no way to tell if similar issues occur when the ATV is outputting 5.1 or 7.1 LPCM and a down mix is not involved, but presumably as the LFE is not being mixed my assumption is that it do not.

There is no reason why MrMC should sound significantly better than Infuse, they are decoding and outputting the same signal on the same hardware. It would also be nice if Infuse provided the option to adjust the LFE mix volume, as well as disable it entirely in the same way as MrMC.

Versions
Infuse: 7.3.10 (tvOS)
tvOS: 15.5

Relevant AppleTV settings:
Audio Format: Stereo (makes no difference set to stereo or auto as the display EDID is forcing 2.0 PCM)
Reduce Loud sounds: Off
Audio mode: Auto

Bump as this audio issue is still a problem on 7.4