Poor ISO playback performance

Hi,
I have just pruchased aTV Flash 1.1.1 for the sole purpose of using the media player for playback of my DVD’s stored as ISO files.
But there is a lot of judder when playing movies from ISO files, as if it skips frames. The more motion in the picture the worse the judder is.

The ISO files are placed on a disk attached to my Airport Extreme, and they are served wirelessly to my ATV2. One could argue that it has to do with the performance of my wireless network, but it is a 5GHz N network without much interference, and when using XBMC for playback everything works fine.

But I would very much like to use the Mediaplayer…

Any suggestions?

If you you need more info for troubleshooting, please let me know.

Hmm, if you can send in a bug report we can try and track down what’s going on.

I am experiencing a similar issue. I am using .dvdmedia files (created using RipIt) rather than ISO’s but the problem is the same. I’m streaming wirelessly also - from a somewhat far flung computer - so currently testing running the .dvdmedia files from a HDD connected to my Airport Extreme to rule out poor wireless connection as the problem. 

The issue either either a framerate issue or a frame dropping issue. Hard to say for sure. It’s watchable, but noticeable and very annoying given that in other ways the picture is superb.

Lkodk - You’re having a smooth experience with XBMC? Am I correct in understanding that ISO’s are similar to .dvdmedia files? That is to say they are the full DVD including menus and so forth?

 

 

I agree to Ikodk post.

I have exactly the same problem with playing ISO/img files. (PAL)
A lot of lagging of the film especially at zooming or “camerasweeps”.
At first I thougt it was à hardware issue in my equipment, but after installing XBMC in aTV, I realize the problem is in the mediaplayer software. In XBMC the files run smoothly as they should.

Still I like the look and feel of the mediaplayer better, so I would very much want this issue solved.

@James: Thanks. Bug report has been submitted.

@tonyh.86307: Yes, with XBMC the playback is smooth. I don’t know .dvdmedia files, but they sound similar to .ISO. ISO can contain a 1:1 rip with menus, extras, all audio tracks etc. or it can be just the main feature depending on how you do the rip. 

Any ideas or progress??

No news. I’ve submitted a bug report which they will look at.
If others have the same issue, I’ll recommend that you submit reports as well, so they can find out what is going on. 

Hi,

I’m having the exact same issue… and still after upgrade to 1.2… Tried both wireless and with cable.

Please fix this issue as media player is so much better than XMBC… :-/

nope. no dice. I’m also still having problems after upgrading to 1.2.

I have reported this back to FireCore in the ticket I have opened.

Again, I urge others having the same issue to open a ticket with FireCore. This may help them track this bug down.

 

 

I think its even worse now!
There is lagging/judder also with xvid films and mkv.
I often use the film “A bug’s life” to check if its running smoothly.
In the first minute of the movie there is a long zooming in on a bug which make it very easy to see if its smooth.

For those experiencing this issue, are you seeing poor performance with PAL videos only, or are there NTSC videos that exhibit this same issue?

Hi! I am witnessing the same problem with iso playback!! Really a shame as i have bought NAS to play my files but the quality is very poor!!

The same problem here with all kinds of files.

The mediaplayer would be awesome in case it would play smoothly. 

I already tried to submit this to support but only received some kind of standard reply without any info asking me to resubmit the whole to support. This feels like ping-pong to me…!

I also feel that this is a framerate issue. Apparently the media player delivers the wrong framerate to the TV.

I tried to set output in Handbrake to all kinds of framerates possible (23,976, 24, 25, 29,97. There are some differences, but no framerate runs really smooth.

I feel it’s the output of AppleTV via the mediaplayer.

Bye

Andreas

 

@James.

I also have the same problems with both PAL and NTSC films (ISO/IMG-files).

I have now also tried the same files in a Boxeebox and they do run smoothly there and also on my computer using VLC.

Hope for a solution since I very much like the interface of the ATV2.

 

// Pauem3

Do you know the refresh rate setting the AppleTV is set to?

You can check this through the Settings --> Audio & Video --> TV Resolution menu. It should either show 60 Hz or 50 Hz.

Right now it sits at 720p50Hz, I thougt that to be the best since I have mostly PAL movies.

BUT of course I have already tried both, with similar or same result. (in any case I couldn’t say that any was good).

 

Ok, if you haven’t done so already, a bug report may be helpful in tracking down what’s going on.

The Apple tv is set correctly. I have tried installing xbmc and the same files Firecore had trouble showing was now playing smoothly.

I see this to, tried both wireless and cable… no difference… Tried Xmbc and the movies runs smoothly. Im using Ripit and ISO (.dvdmedia).

 

Will try to contribute with a report.

 

Hoping for a fix soon, cause the mediaplayer is so darn good in every other aspect! I hate Xmbc…

My problem with ISOs has taken a dramatic turn, from poor performance to NO PERFORMANCE at all!

Right now I can’t play ISO/IMG files in mediaplayer whatsoever.

When I try, aTV crashes after a few seconds. It first seems to start the movie, but then the screen turn black and stays black (waited ten minutes, several times).

The only way to get out of this is to disconnect the power.

Exactly the same files plays without any problem in XBMC.