Plex vs SMB Shares


I installed Infuse on my Apple TV as the Plex client for Apple TV had buffering issues even over a hardwired 1 gigabit connection. It appears to be having the same issues in Infuse when connecting to the Plex server.

If I connect using standard Windows SMB file sharing, everything works perfectly. Even fast forward and rewind is smooth.

Is there any reason why using Plex has so many issues? I prefer Plex as I have other non Apple devices also that need to have the library stay in sync.

I believe this is something to do with the Apple hardware though. Plex runs perfectly on Roku.


You can try running a speed test for both shares to see how each share type performs.

This option can be found in Infuse > Settings > Shares > Share Name

Simply select a video file to use for the test, and you’ll be able to see the max speeds for each share type.

Are you on the same subnet as your Plex server? It could be trying to trombone the traffic out your wan and back in again. In your network setting put in the network address for your local lan subnet ie:

This will force everything on that network to be treated as local traffic


Same subnet as the server.

Speed tests for both SMB and Plex are 900 mbps+ up and down. Still get a spiking wheel when using Plex after a few minutes. Once that happens it stays that way and will not resume.

Very strange. I don’t have any buffering issues.
I’ve attached my network settings for plex.

Are you testing speeds via Infuse or via some other means?

Infuse won’t actually show the upload speeds, and 900 Mbps seems extremely fast for SMB.

Yep, I used Infuse. Maybe there was no upload speed but the 900 mbos for SMB is definitely what I was getting from it. This is a hard wired connection rather than WiFi. The server is Windows Server 2019 on a VMWare server. The bandwidth from the server to the switch is 3 gbps as 3 of the physical NICs are using Cisco port-channels. It is a 48 port Cisco Catalyst switch.

I am going to replace the switch near the TV with a gigabit Cisco Catalyst switch on Tuesday. Right now that one is a Netgear smart switch. I am having the same problems with the Plex app also on Apple TV.

Ok, let us know how it goes.

900 Mbps over SMB may be a new record…congrats! :slight_smile:

That’s probably why SMB works so well. :slight_smile:

Aren’t those things a little loud to be by the TV? I know the old 3759 and the newer 9300 and up series are screamers.

Meraki gives away 8 port fanless ones with a 3 year subscription if you attend a webinar and use a business email.

That netgear Switch is probably causing issues. It doesn’t matter whether you use their consumer or “enterprise” equipment it all seems to be junk.

I will be using a Cisco C2960 8 port compact switch. It is a fanless model also.

1 Like

900?? How ?? I’m using the ethernet connection and getting 120mbs directly from a Apple Timecapsule. And 90 max from a Mac Pro 7,1. Getting 950 max on the same connection with a plex share. Is macOS bottlenecking me with their SMB ?

Time capsules are pretty slow to begin with. I only use one for backups.

It’s possible that Mac is not as fast for SMB shares as Windows Server is. Also, I have 3 NICs on a port-channel from the server which makes it equivalent to a 3 gbps connection also. That may have something to do with even though ultimately the connection to the Apple TV is only a single 1 gbps port.

Have you tried connecting via WiFi? Just to exclude any wired network issues…

I use ATV 4K with PMS on a Synology NAS and I can assure you that the PMS performance is noticeable superior then SMB when streaming. Similar speeds but less lag when starting or resuming. Plex is just more responsive.
No buffering at all even on high bit rate 4K HDR movies.
My connection is a hardwired Gigabit network straight from my router (ZTE from my fiber provider)

Yeah I did try the Wifi… it’s slower. But the ethernet connection is fine as the Plex share gets the full 1GBps. I will try a Windows SMB share a see what brings me…

I can upload to the Timecapsule drive from my mac @ approx 50 MB/s so thats around 400Mbps. I only use this as a temp storage for weekly TV shows and stuff. And yeah mainly for backups of all the Macs in the house.

My main library is on my Plex server. But thats also on a Mac…

Let us know if the new switch works. Are you running any sort of NMS that can poll your switches for snmp info? I’m just wondering if you’re getting some errors or possibly dropped packets somewhere? If you are running anything I’d recommend spinning up a Linux VM and throwing LibreNMS on it. This should give you port statistics on each interface involved.

Okay when you get buffering can you check if transcoding is happening which should not be happening. Apple TV had all hardware decoding capability only Plex app transcode audio but infuse just do on the fly no trancode needed .

the OP’s issue is exactly the opposite of mine. Its really weird. My Plex share on Infuse runs very smooth, no buffering on 100… even 200 mbps 4k movies. The SMB on same server buffers like crazy…

Replaced the switch and did not resolve the problem.

However, disabling large send offload on the NIC resolved it. Playback using Plex works perfectly now.