Plex TV Series shown as Other

How do I get tv series to show under ‘tv shows’ as no matter what I try I can’t get it to work - my movies are fine, its just the tv side. These are shown correctly in Kodi & Plex without any issues

tvseries01 tvseries02

I’ve tried different layouts for the naming convention, yet none seem to work

Are they showing up under the “Other” category in the Library instead of the TV show section?

Every single episode for all my tv series, nearly 700 episodes in all

I’ve cleared the cache, relinked it back to plex, rescanned and get the same

And when you go into Other it just lists every episode by itself

I don’t have apple phone or tablet so can’t see what it’s like on them.

Media is stored on a networked pc running ubuntu headless 18.04.1 using samba shares

Plex Server is installed on ubuntu and works fine on apple tv 4k and also my android devices

Have you tried connecting directly from Infuse via SMB to the file server skipping Plex?

Not yet, but that was part of my next diagnostics

But I used the plex link so my watched titles got past back to plex, so plex and tautulli see it.

Update: Managed to get it to connect via smb directly (would be good if could browse and not have to manually enter)
Added the 3 folders for the TV series as on different shares for different drives as favourites and hid these so not on front screen.
TV Shows now contains the TV shows as expected, so not sure why working via smb but not plex link.

I don’t run plex so I have no clue as to why it doesn’t work that way but glad you got it working! :smile: Maybe one of the Plex gurus will chime in as to why this is.

Are these videos set up in a ‘TV Shows’ library in Plex.

Do they contain correct metadata when viewing them in the Plex web UI?

When using Plex, Infuse will rely on Plex to categorize the shows correctly and provide metadata. It will use the metadata provided by Plex instead of fetching its own from TMDb/TheTVDB.

As per my op, they show perfectly under plex and kodi

these are taken from the plex webgui

Can you post a pic of how these appear in Infuse while using Plex?

Can you try using the ‘Refresh’ option in Infuse while viewing the video details to see if this helps?

Under favourites I have library, movies, TV shows, other, mediaserver

But if I go library they listed as single episodes.
TV Shows - just shows firefly after a lot of messing about without any changes to the filenames
Other - lists as single episodes
Mediaserver - go into TV series and all listed in series.

But I think the last is just accessing via direct smb and not through plex.

I’ve even downloaded and ran tiny media manager but no change

If go into title then choose refresh it moves into TV shows.

Also all my shows are in dvd order not aired order

I’ve had the same problem until I created subfolders for each season (Season 1 or Season 01 etc). Without that episodes were detected as movies and since not found marked as other.

if you see my posts, they are already in the correct format

I’ve used tinyMediaManager and told it to save the nfo files which seems to be working outside of plex - just got to tell it to look at plex and see if they are now showing correctly (just not had a chance yet)

Can you provide an example of how these files are named?

Do you have the ‘Metadata Fetching’ option enabled in Settings?

See my earlier posts in this thread showing the file naming convention used.

Metadata fetching is enabled with embedded off.

not sure why its \top level\directory\series001<tv show name>\season 1??
ie \network\mediaserver\series001\firefly\season 1 - it seems duplicated/redundant to me?

having used xbmc then kodi for years as well as infuse pro, naming conventions can be picky, and then people cause issues with thetvdb…

i would suggest trying \top level\tvshows\tv show name\season01
that should do the trick, but from my understanding, metadata is at the mercy of the database you use to scrape data…

There is nothing wrong with the naming convention

That’s because the top level is made up off.

Network is the network it is on
Mediaserver is the server name
Series001 is one of the share names containing all the series (as I have series under different locations and have multiple shares on a server for different things, so doesn’t matter if rename this to tvshows, tvshows01, tvshows02, etc, etc)

The TV series are then listed in the share under their own names with each containing the season number and episodes.

This has worked since original xmbc and works with kodi, spmc, ember, jellyfin, plex, tinymediamanager and infuse if use direct shares.

I’m having the exact same problem. Things are classified in Plex correctly, files are named correctly, but Infuse is a mess.

Everything was working fine for the past few months. Then I added a new library drive and renamed a few network shares, and Infuse fell apart. I deleted and recreated my Plex share in Infuse, and now I’m in the exact same boat as you. All my movies are fine, but every TV Show is now in Other.

Everything in the Plex app is completely fine. I’ve got three libraries classified as “Movies” and three libraries classified as “TV Shows.” Everything shows up correctly.

Infuse does a great job at playback, but the whole reason I have a Plex server is library management. Hopefully this is a recent bug they can fix.

Yeh, Plex is good for library management and as a LPM I won’t be removing it especially as I use it on Android devices and TV’s - I originally got infuse as saw it said it worked with audio passthrough :frowning: which as with other apps on apple it don’t - plus plex provides me with information on what is playing, etc and means I can start on Apple TV and move to Shield TV, Android devices or LG TV’s and picked up where I left off.

Now with infuse this would still work if used the plex library, but it doesn’t show the tv shows properly which is the big let down, so I can’t pick up where I left off on another operating system - if I use direct sharing (as I would in Plex) then it shows fine which suggests its an infuse/plex compatibility issue - i am slowly getting some showing correctly but that is only by using TMM and saving NFO files, etc in every folder which under Plex and Kodi, I never have to do and this is just wasting storage space on my server with un-necessary content.

Also Infuse has a better layout than Plex on Apple TV as it provides more of an apple interface compared to plex.

Is this still an issue for you in the current 6.4.4 update?

If so, can you try viewing one of these items and hitting the Refresh button in Infuse to see if this makes a difference.

Lastly, if the issue persists can you send in a report from the Apple TV (Settings > Submit Diagnostics) and let us know the series which are appearing in the Other category?

I’m having the same issue. I just began using infuse but I’m not using Plex to store my files. I’m using Google Drive. I have a TV Shows folder and a Movies folder. All my movies are displaying correctly in the Library as Movies, but everything else is Other. This includes home movie clips as well as all episodes of TV shows. When searching and I select “All TV Shows” the “Empty Folder” message appears.