Plex Trash causing "An error occurred loading this content"

First off thanks for the awesome media player, and I’m a happy customer of the lifetime pro version.

Apologies if this is a known issue or duplicate post. I spent some time searching, and I don’t think this variation hasn’t quite hasn’t come up. I also contacted support several days ago without a response yet.

First for background, I’m using the latest Infuse as a client to a the latest Plex Media Server, and this error occurs consistently across iOS/iPadOS, macOS, and tvOS. The first party Plex clients do not have playback errors on the same content. This issue has occurred for the last >6 months, and I’ve been vigilant about updates hoping this gets resolved. It occurs irrespective of content type (e.g., SDR files, HDR files, etc.)

The specific issue is when a) a particular TV show episode or movie has multiple files associated in PMS, b) only one file remains on the local storage as the others were deleted, and c) the PMS trash hasn’t been emptied it yet.

When Infuse attempts to play the content in these situations, it asks which version to play. I select the correct version, and then it presents the error “An error occurred: An error occurred loading this content” and is unable to play. (I’m also certain it’s the correct version, as when selecting the other options presented, Infuse correctly presents an error about the file being deleted.) When I go to the PMS and empty the trash, and then go back to Infuse to play, the file plays back correctly.

This was not always an issue with Infuse. I can’t say with which version for this started happening, but I think it was >6 months ago.

Appreciate the help investigating and resolving this. The workaround is to empty trash on the server, but that quite inconvenient when away from my server.

Looking ahead, once this issue is resolved, it would be ideal for Infuse to be smarter about picking versions. If all but one version of the file is not available / is deleted, it should only play the available version without prompting the user.

Thank you!

Just a suggestion, instead of saying “latest” version you may want to put the actual version numbers since updates are so frequent and trying to compare makes it easier when all is known.

1 Like


Infuse is 7.3.4 (7.3.4009)
PMS is

It’s been happening for several versions though, and apologies, can’t pinpoint the version where it started. My setup has been stable, so can’t think of other things that might have changed to cause this.



7 posts were split to a new topic: An error occured notice and sleeping NAS

@anquieta I apologize that I got your thread a bit off the rails but I split out the other info to a new thread. :wink:

I don’t use plex but from reading it sounds like plex keeps the metadata on files that may have been deleted and their kept in the trash. When you empty the trash in Plex that just deletes the metadata from the deleted file. Since you get all the metadata from Plex it’s still sending the metadata to Infuse even though the actual video may be gone.

I’m guessing there must be a setting somewhere to turn off the trash in Plex so it won’t be seen by Infuse but that’s only a guess.

Here’s where I found a bit of info about it. The info I’m referring to is a few posts from the start.

Thanks @NC_Bullseye.

You’re roughly right about what we could call “zombie metadata,” and that’s why doing the PMS “empty trash” solves this. There is no feature to disable the trash. There is an automatic empty trash periodically. However, then if a drive goes offline accidentally, Plex will automatically delete all metadata related to all files on that drive. For this reason, I have this automatic feature disabled, and I do manual empty trash myself time to time.

We are talking about workarounds though, and we’re not talking about the issue with Infuse. I’m fairly advanced on how Plex works, and frankly, I don’t think the problem is there. It’s with Infuse. Like I mentioned, in earlier versions there was no problem with this.

I had some time to do some more testing, and I discovered something interesting that might help debug this.

First, I tried doing a full metadata refresh in Infuse. After Infuse downloaded the metadata again from Plex. This issue remained.

However, when I deleted the app, reinstalled it, relinked the PMS, and Infuse downloaded the metadata again, Infuse was then able to correctly load the available content, even while there was “zombie metadata.” I tried the same exact TV episodes and movies that were causing problems before.

Now, here’s where it gets interesting. I moved some files around to create this “zombie metadata” situation with a new TV episode and movie. Infuse did a scan for changes and updated. It now demonstrated the same error again on that content. I also went back to check other TV shows and movies that also had “zombie metadata” previously but had started to handled correctly after the full app delete and reset, and that continued to work fine after this scan and partial metadata update.

So, I think this helps narrow the problem down to something related to how Infuse does the scan for changes and partial update of the metadata database from PMS. A full app delete and reset fixes it, but only for the content that gets entered into the database during that process. For some reason, a full metadata reset doesn’t fix it the same as deleting the app and setting it up again.

Hopefully I’ve explained this clearly, as it’s a nuanced situation. I don’t think it’s quite an edge case, as it comes up when content is updated/upgraded in the PMS library and Infuse does a scan and partial metadata update. Hope this is something we could pass to the support/dev team to look into?


I’m going to have to step back since I am pretty much in the dark when it comes to Plex. I don’t use it and know just enough to really confuse things at times. :wink:

I changed the title of this thread to hopefully draw more input from others who may have a solution. There must be a setting somewhere since I don’t recall any similar issues being discussed.

1 Like

Just another random thought, is there any way to locate the Plex “trash” somewhere that Infuse doesn’t look at such as a different directory?

Short version is that it doesn’t work that way. The trash is not an actual location. :grinning: As PMS scans files and folders, each TV show and movie entry has file paths linked to it among all its metadata. Each entry can have multiple file paths for multiple versions. Sometimes those versions are deleted on the storage (updating from a DVD rip to a BluRay for example). When PMS sees this, it remembers the file path but marks it as unavailable. The metadata for these unavailable items is what is purged when using the “empty trash.” I suppose they really shouldn’t call it trash. It’s really just a purge of defunct file paths.

Is there anyway to get this on the radar of the support team? It’s been a week and there’s been no response to my support ticket. Thanks.

Just as a thought have you looked at PlexAutoscan if you run a PMS.

I believe it can be installed on any OS that Plex runs on. I currently run it on docker Linux and have previously ran it in windows.

This is assuming that your workflow is along the lines of Radarr/Sonarr upgrading files and Plex putting the older file in trash.

Difficult to link via mobile but search “GitHub Plex Autoscan”

Apologies if your work flow is different.

In PMS under the settings section (left panel) Library: there are two items. 1st: Scan My Library, you can set this from every 15 mins up to daily. 2nd: Empty trash automatically after every scan. How do you have these two set?

Thanks all.

The issue isn’t with autoscan (so I don’t need another app for that). Changes are detected instantly, and like I said, the first party Plex client has no issues. Just Infuse. And Infuse itself has no issues in a prior version last year.

As far as the PMS settings for scanning, I have them set to scan automatically, and that works to detect changes. The issue isn’t PMS detecting changes, those happen instantly on the macOS version of PMS at least. I have deliberately turned off automatic emptying of trash, as I don’t want the trash emptied when a drive might go offline and then lose all the metadata associated with the items that were on that drive. (I’ve had this issue in the past, and it was a time sink to work through.) Things are working as intended on the PMS side and with the first party Plex client, and in the past, Infuse had no issues with it, and these settings have not changed for years on my server.

I appreciate everyone’s time and ideas to workaround this, but from what I can tell, the issue is very likely a bug in Infuse, especially given the inconsistent behavior between a full app reinstall and a scan for changes/partial metadata update, and also given that it wasn’t a problem in a prior version of Infuse with the same PMS settings. I’d appreciate if someone from the staff, maybe @james, could take a look, and I’m happy to do more testing and send logs if helpful. Thanks.

Strictly for me to learn a bit, if Plex tries to scan a drive and it’s off line would it still try and empty the trash if it didn’t complete that scan? Wouldn’t it error out and not complete the scan?

I understand that it wasn’t an issue until recently but to me it seems we’d have far more people posting with this problem if Infuse had changed and caused this. Not saying it isn’t Infuse but not sure where to look to see what updates plex has had recently that could also be at fault.

I haven’t tried it recently because of a bad experience in the past. My experience is that it will think the files on that drive are not available and thus “trash” them.

Totally understand. Not sure why this hasn’t come up. Hypothesis could be that most folks do empty trash automatically and do not care about lost metadata (e.g., watched status, play history) in a situation of a drive being offline.

I don’t know what else other than a potential bug could explain that a) this issue does not occur on a fresh install and scan but does occur on a partial scan for new content with multiple versions, b) does not occur for the Plex first-party client interacting with the same content on the server, c) did not occur in an earlier version of Infuse. But I’m open to other ideas!

This is not an issue we’ve come across in the past, but we may be able to add some special handling.

Can you replicate this issue, and then send in a report from Infuse (post the code here)?

1 Like