Plex on 4.4.4?

The latest blog entry suggests that plex should work, anyone know how to install it?