Plex not playing videos / HTTP 500 error

I have solved this by connecting my jellyfin server instead but still would like to know why plex didnt work? must be a setting somewhere


Bought an apple4k and have downloaded Infuse and signed up for a yearly subsciption, i connect my Plex server (previously running through an Nvidia Shield) to my infuse it found all the movies / tv and metadata but when i go to play anything i get

‘an error occurred loading this content. HTTP 500 (internal server error)’

Not sure what i have done wrong or how to rectify this?

Thanks for any help

There’s a users guide that may have some trouble shooting help.

Hi, I get this error as well. Are you using a VPN ? Are you on local network ?

Here is my problem : when I try to play a movie in Infuse that is in Plex it will not play and give this error HTTP 500 (internal server error) :
Capture d’écran 2024-01-14 à 22.31.04

I have the error on my iPhone as well.

Here is the config and what you need to know :

  • Movies are stored on a Mac mini at home
  • Tailscale is working fine for other things. I can access my Mac mini files from outside using my iPhone for instance.
  • Plex is installed and working just fine on local network
  • I can actually use Tailscale and and I can play movies just fine.
  • Internet speed is more than fine.
  • I tried using SMB and SFTP (on Tailscale over Internet) so that I don’t have to use Plex but weirdly everything will be fine and then after like 15 min it will endlessly load. I read online that Plex should in theory not have such problems.

I tried to Google stuff but I could not find anything regarding Infuse, Plex, Tailscale, HTTP 500 (internal server error). Maybe I used the wrong keywords but I am a bit desperate.

Thanks a lot in advance.

Also it does appear that I can browser the server just fine :man_shrugging:. Normally when a server is not avaible (if I have the Tailscale IP but VPN off for instance) it will just load endlessly.
So something is telling me that it is working, just not in the right way.

Also I found this post on the forum of someone who had a similar issue. But saldy his fix was using a VPN and in my configuration I have to use the VPN anyway, but who knows maybe that can help.

Here again, a proof that it is working and that I can browser the files but when clicking on “Start test” it will show “Stop test” for like 5 sec and then do nothing.

Here is someone that apparently has the same problem as me : Reddit - Dive into anything

He did not give that much of details but it’s globally the issue resumed.

Currently, Infuse will direct stream all content from the Plex server in the original format, without transcoding. This means the upload bandwidth settings will need to be set high enough (around 2x the average bitrate) for the videos being played. If this is not done, then Plex would not be able to deliver enough of the stream for Infuse to play, and could result in errors like this.

There are also cases where Plex may be directing traffic through its relay service which has a rather low bandwidth limit. I don’t believe Plex as an official way to disable this service, but there are some suggestions on doing this.

this is what worked for me to fix this (not sure which one actually fixed it)
Plex → Settings → Network

  1. Clear checkbox on Enable Relay
  2. Under LAN networks, make sure the network(s) the Plex Server and the AppleTV client are on are listed; format is,

for some reason the infuse client is seen as a remote and tries to go through the relay server, which is bandwidth limited.

I am seeing this 500 error when trying to connect to my movies Folder but not when I try to open my TV Shows folder.

I can access movies by showing my library and navigating to them that way but I see a message stating indexing with my plex server failed so there’s definitely something wrong.

Everything has been working fine for years so I don’t know what has changed. I don’t have plex pass so don’t have access to all the network settings mentioned above but as everything was working until recently I don’t changing those is likely to solve this issue.

Hopefully this can be rectified soon. :confused:

I’m using Infuse on Apple TV and Plex Server via different VLAN network and there is no VPN connection.

  1. Apple TV : /
  2. Plex Server : /
  3. Switch/Gateway : Unifi UDM PRO, USW Enterpise 8 POE and it using igmp proxy demon.

I’ve tried to uncheck “relay server” and put the Apple TV’s IP and subnet ( to Plex LAN network setting, “http 500 error” has been disappear but plex media cannot still playback.

Please let me know how to solve this problem.

Infuse working great with Plex, Apple TV, Sonos arc soundbar and 7yo Sony qled.

But getting HTTP 500 errors with Apple TV, new lg inexpensive 4k tv and generic soundbar. Only happens with 4k movies nothing else. Is there a setting I can change? Getting no Dolby in app install recommendation like I did with other tv just won’t play

I have rectified the bandwidth issue but now getting 503 service unavailable errors. Would really love to use Infuse with family but not sure how to get past these… are there any troubleshooting steps for 503?

same problem.

  1. I can watch movie without issue via plex app on ATV
  2. Speed Test on infuse → movie file on plex server → Error
    ATV 17.3 (21k646)
    Infuse 7.7 (4729)
    Windows 10

I downgraded Plex to previous version doesn’t fix problem

Updating… what ultimately worked was adding the ip addresses as someone did above.

tried add IP address above still doesn’t work.

Did you try this?

my Limit remote stream bitrate
Original (No limit)