Plex new release - ATV Flash 2.0

Hi… Would the new ATV Flash 2.0 version include the new Plex client released Sept. 1st ??

As far as I know, ATV FLash never ‘includes’ any 3rd party apps - it merely allows you to download the latest version in the applications online repositories.    Have you tried seeing if that new version of Plex can be installed using the current version of ATV Flash?

It can not at this stage. I had to install it manually using the install method provided on the Plex forum… As a matter of fact, the Maintenance menu no shows UPDATE next to Plex… but it is no update… it points to the previous version (which was full of bugs)…

Anyway, maybe it is Plex responsibility to make sure it is hosted properly so that users can update… I hope for everyone loving Plex that they do… the new client fixes everything that went wrong when iOS 5 got launched…

The updated Plex plugin is available through the Manage Extras menu, however due to the way this update is versioned (old version was and new version is it will not appear as an update. I’ve no idea why they’ve chosen to version it this way.

To update, you will first need to remove the current version (highlight Plex and press right arrow button), restart the Apple TV when prompted, then reinstall via the Manage Extras menu.

Thanks James

Actually when I looked in the Maintenance menu, Plex showed as NOT INSTALLED… while of course it was… I just proceeded like a new install and it worked just perfect. I checked in Plex after to verify if I had the correct version installed… all OK !!.. or so I thought

The Maintenance menu kept showing Plex as NOT INSTALLED. So I had to manually remove Plex by ssh using terminal and running a apt-get remove com.plex.client-plugin command. The I rebooted the ATV and went back to the Maintenance menu. I installed Plex from there… I checked… good version… but still showing as NOT INSTALLED…

Anyway… I don’t really care… cause I know it is installed… might be something to fix… I’m perhaps not the only one like this…

You’re right ! Weird of Plex team to label the new version with a lower number… go figure !

Anyway… thanks for the quick reply… as always you guys rock !

I’ll be waiting to try the 2.0 version soon…

Having the same experience. PLEX is installed and functioning well, but maintenance screen indicates, Not Installed.

Should be fixed with the release of 2.0.

Plex has a new release as of September 22. It is not showing in the Maintenance menu… Should we wait or should we proceed with manual install ? New version is 0.10.106

The new Plex update is now available via Manage Extras.


Hi, I just installed 2.0 on 5.0.2. Tried to install Plex from “Manage Extras” and, tada, never ending boot-loop. Uninstalled from CLI (apt-get) and tried again… Same problem! In Manage Extras it says Plex version: 0.10.107… Any advice?

Hmm, your best option will probably be to let the Plex folks know here.

That said, there have been a few reported conflicts between XBMC and Plex, but usually that results in XBMC crashing, not Plex.