Plex integration connection fails with an error

When I try to save the Plex account within Infuse after the Plex link (with a PIN code) has been approved, Infuse complains that it “encountered an error while trying to connect.” MrMC’s Plex integration works so I assume this is an Infuse problem.

Any ideas how to fix this?

Try changing plex server network secure setting to „preferred“ (its a Plex Setting, not infuse) or change your devices DNS Server to Google

Both settings were already set to your recommendations.

Make sure your plex server is updated to the latest version

Are you trying to connect to a Plex Cloud server by any chance? I requested that feature but it didn’t made it in the current version, so it’s not supported at the moment. Hopefully the next one will support it (but it’s currently not mentioned in the upcoming feature thread)

Does Infuse only support the most recent version of Plex Server? I have an older version of Plex Server which is restricted by my hardware. MrMC supports it so I assumed that Infuse could to by using the same APIs.

I was running an older .9xxxxxx plex server version and had to upgrade for it to work. I bet it’s your problem.

That must be it. I’ll be replacing my old Mac Mini HTPC soon with a newer model that can run the current versions of Plex Media Server.

Same problem for me, I have mine set to secure “preferred”, not “required,” I also checked “server IPv6 support” just in case that might be the issue. I did skip the very latest PMS update because I don’t use the DVR features, and the update only mentioned updates to DVR features (I’m on 1.12.2.4929). I’ll try updating.

Actually, I realized I don’t have the same error at all as the OP. Instead of error trying to connect, I get this error:

“An error occurred loading this content.”

Server:
Plex Media Server 1.12.3.4973 (latest beta)
OS: macOS 10.13.4 (latest High Sierra)
Hardware: 2017 iMac quad-core i7 4.2 GHz 20GB RAM 512GB SSD 12 TB RAID 5
WAN: Cox DOCSIS 3.1 “Gigablast” 1 Gbps down / 35 Mbps up

Clients:
Infuse Pro 5 v5.7 on iPhone X on iOS 11.3
Infuse Pro 5 v5.7 on Apple TV 4 (non-4K) on iOS 11.3
WAN: 100 Mbps cable modem connection

Both Infuse Pro 5.7 clients do:
Connect remotely to PMS fine
Add all my libraries from my Plex shares
Browse posters for all my libraries

But it won’t play any movies. I get 30 seconds of the spinning wheel, then the error message, “An error occurred loading this content.” Every time, same error on both iPhone X and ATV 4.

I have tried the following:

  1. Restarted my Apple TV 4
  2. Hard reset my iPhone X
  3. Updated PMS to latest beta above from the previous version, 1.12.2.XXXX
  4. Deleted and reinstalled Infuse Pro 5 on Apple TV 4K, restarted Apple TV 4

I have NOT tried:
LAN connection of Apple TV 4K with iOS 11.3 / Infuse Pro 5.7 (I’m away from home until tomorrow)

No joy. Any help would be greatly appreciated!

I have the same issue as Davidhan mentioned.
Raised already ticket https://support.firecore.com/hc/requests/102797
Let’s see what happens.

I also put in a support ticket on the evening of the 5.7 release, no response yet.

If you’re having trouble with remote streaming, one thing to check would be your upload bandwidth settings in Plex.

Infuse will currently direct play everything, so having an upload limit below the level of the video you are trying to play can cause issues.

We’re planning to add some smart transcoding options in an upcoming version that will allow for some more flexible remote streaming capabilities, so stay tuned. :slight_smile:

Hi James,
no thats definitely not the issue.
As I wrote in the ticket, it looks like that movies which are in own Subfolder are nor possible to watch. Some movies are on Top-level of the “movies” folder are possible to watch.
I get also no request on the plex server from infuse in that case.

Christian

I’ll look into this possibility. I only have untranscoded Blu-ray rips, and only 35 Mbps upload speed. I read that Blu-rays have high 20s to mid 30s Mbps, so a lot of them should work. I tried older movies like Nacho Libre and My Cousin Vinny which generally have lower bit rates, but no go. Once I get home I can see if local lan streaming will work, since I have 300 mbps WiFi speeds to the 4K ATV.

I will look into Eigi’s assertion as well re: sub folders. I have no sub folders inside any of my media folders, but none of my movies are on the top level directory of the volume.

Looks like there are several different issues in this thread. I got home, Infuse Pro 5.7 works BEAUTIFULLY on my local WLAN with PMS and 4K HEVC MKVs, even supports Direct Play from Plex with subtitles (normally PMS has to burn in subtitles which requires transcoding 4K video, not a mean feat). THANK YOU FIRECORE!!! I love my 4K Apple TV, it just simply could not play back 4K HEVC files smoothly with PMP, and while my Samsung TV’s Tizen Plex app DOES play 4K movies, the movie posters appear to be in 720p or 1080p, not the glorious 4K that the 4K ATV and my Samsung 82" 4K display are capable of. Now all I need is Atmos/dts:X support and I’m one happy clam.

The error I’m encountering may well simply be that my upload speed isn’t supporting uncompressed Blu-ray 1080p bitrates. I may have to make an optimized library or just watch my digital library via iTunes/Vudu/MoviesAnywhere when away from home.

James, I installed Tautulli and have more detailed information on bit rates. I think you’re on to something. I had tried several movies remotely, and all had failed. Here they are, with their original bandwidth and their Streaming Brain Estimates:

Nacho Libre: 25.5 Mbps, SBE 28.3 Mbps
My Cousin Vinny: 21.1 Mbps, SBI 38.4 Mbps
Anchorman: 39 Mbps, 43.8 Mbps

Theoretically, Nacho Libre should have worked (I have 35 Mbps upload speed at home), but everything else I’d tried and quite a few more movies I tested tonight had SBEs above my 35 Mbps rated upload speed. This is truly a bummer for 2 reasons: 1) I was not going to transcode my movie library so I could keep full Blu-ray video quality, and 2) I have Cox Gigablast but I can’t stream ONE movie in Blu-ray quality (940 Mbps down, 36 Mbps up)!!!

I may have to use my home PMS for home LAN playback only, and set up a duplicate of my Plex Media Server off-site where I have 150 Mbps upload speed for remote access. This would give me a backup of my library, but it would also double my storage costs. I see after all these years, we’re still on the bleeding - unsupported - edge (no Atmos / dts:X until who knows when?).