Plex episode is marked as watched if you cancel playback immediately after episode has started


I use Infuse connected to a Plex library. I usually watch series in continuous play. If I cancel the playback of an episode immediately after it has started, it is marked as watched next time Plex is synchronized. This does not happen when I play the series on Plex.


If this happens again, can you drop us a quick note from your device?

Here is a sample. After episode 9, episode 10 is played. When canceling the playback of episode 10, it marks episode 10 as played. This happens on every TV Show. I will try to reproduce on iOS and send logs.

Thanks! We’ll take a look into what’s going on here.

In iOS it has the same behavior.

I’ve sent request #119459 from iOS.

BTW If If let the episode play until it’s resumable, it’s not marked as watched.

Thanks. That is helpful to know.

We’ll figure out what’s going on here.

1 Like

Another thing I’ve seen. It’s not related to continuous play, if you play a single episode and you cancel playback before reaching resume time, it’s also marked as watched. This doesn’t happend on movies, only on TV shows.

Just happened to me as well. I’m running the latest Infuse and tvOS beta though.

1 Like

The issue still persists in version 6.1.5. Any progress on this? Have you been able to reproduce the bug?

I’ve done a test, I’ve uninstalled Trakt on Plex Server and I’ve enabled Trakt on Infuse. Apparently this problem has disappeared magically. I will do more playing tests and report the results.

Do you use Trakt plugin on your Plex Server?

No, issue persists. It takes longer, but If you cancel playback when episode is not resumable, it’s marked as watched. Please fix it asap because I miss episodes without realizing. I have to be carefull and remember the last watched episode.

Is there any chance that this is fixed in the next release version?

Bug still present in version 6.1.7

Hey guys, same issue here. I hadn’t made the connection of this triggering when cancelling playback on startup but that makes sense now. When I get to the end of an episode, I typically hit the “Chapter Up” command on my Harmony to skip past the credits and force the next episode to queue up from the start. If I’m not planning on watching the next episode right away, I then exit out.

Hey, I just did some more experimenting and have some additional observations. The short answer is that this may be a problem with the Plex server, not Infuse.

I flagged the last 2 episodes of a show’s season as unwatched, then started the first of those 2. After a few seconds into playback, I chapter-forwarded to the end to force the next episode to start playing. After a few seconds, I exited out the the list of the episodes for the series. At this moment, the last episode was still flagged as unwatched. When I backed out a level, the season showed in my “Recently Added” list up top with the orange bar still indicating that there were unwatched episodes. Going back in and out had no effect on the “unwatched” status of the episode. When I forced a refresh from the icon up top, the episode at that point got flagged as watched (and thus, the whole season).

From that, it seems Infuse is getting the “watched” status from Plex, although if it’s sending something to Plex to make it think it was watched, I cannot say.

EDIT: ok, I don’t think it is the Plex server. I can’t replicate the problem on Plex’ own app on the ATV. But here’s what I did find. After forwarding through the first of those 2 same episodes to get to the second in Plex, and after aborting playback of the 2nd after it started, that last episode remained flagged as unwatched in Plex, and showed the same in Infuse. When I repeated the process in Infuse as before and got the “watched” flag applied incorrectly on that last episode, I went back to Plex and Plex still correctly shows that same episode as unwatched. If I check directly via Plex Server’s web browser interface, it also still correctly shows that episode as unwatched.

Before this happened on both iOS and tvOS. Now it seems that it only happens on tvOS.

I confirm, I have the same issue on tvOS.

Problem persists on version 6.1.8. This is highly aggravating. I had to turn off Continuous Playback so I wouldn’t get burned by this.

1 Like

I’ve also disabled continuous playback.